The 1947 - Present Chevrolet & GMC Truck Message Board Network

The 1947 - Present Chevrolet & GMC Truck Message Board Network (http://67-72chevytrucks.com/vboard/index.php)
-   The 1988 - 1998 GMT400 Chevy & GMC Pickups Message Board (http://67-72chevytrucks.com/vboard/forumdisplay.php?f=12)
-   -   1990 TH400 Problems (http://67-72chevytrucks.com/vboard/showthread.php?t=459092)

SoCalSlaughter 04-13-2011 09:09 PM

1990 TH400 Problems
 
I have a 1990 Chevy V2500 Suburban 4X4, has a TH400 on it. Just about a week ago the trans started to make a horrible whinning/shuttering sound, someone told it was because I was low on fluid. I work at AutoZone, so I just got a new filter and fluid, did a service on it. The noise stopped, but now its been having trouble shifting from 1st into second. If I'm hard on the gas it will finally shift, but sometimes I have to manually shift it. Another thing is when it gets into 3rd like on the freeway, and I give it gas past 55mph, it will slip out like its put into N. If I put it in N and back into drive it will engage 3rd again and keep on going. Also its been getting hot. It seems that once it gets hot, is when its starts to have this shifting/slipping problem. Anyone have any ideas?

Also, 3 days after I did the fluid change, I checked the fluid level and the fluid was no longer red, more like a dark grey/silver color.

68steppsidee 04-13-2011 09:52 PM

Re: 1990 TH400 Problems
 
needs a rebuild

SoCalSlaughter 04-13-2011 09:53 PM

Re: 1990 TH400 Problems
 
Thats what I thought, quoted a bench rebuild $500


All times are GMT -4. The time now is 07:54 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com