View Single Post
Old 03-18-2017, 05:15 AM   #23
Ironangel
Senior Member
 
Ironangel's Avatar
 
Join Date: Feb 2010
Location: Falls City,Nebraska
Posts: 1,382
Re: Transmission? Poor acceleration.

When is the last time the motor got a new set of plugs? If the trucks been sitting for any length of time before the mishap, maybe bad fuel and or a clogged fuel filter? Also, over filling the crankcase can lead to fouled plugs. Might take a look at the wires and caps on the distributor making sure they're all fully pressed on to the terminals. It's easy to inadvertently pull a wire loose when pulling the transmission fluid dip stick. I'd definitely install a new set of plugs before I gave up on the transmission. The fact that the 350 turbo is still pulling the truck is testament to how tough they actually are. If you did fry the clutches there should be some tell tale indicators such as a burnt smell in the fluid as well as suspended clutch material in the fluid causing it to be a bit darker than the bright red translucent fluid that was added. If the poor acceleration proves to be some fouled plugs, I'd buy the tranny a pint of this, http://www.lubegard.com/~/C-303/LUBE...uid+Protectant and myself a six pack of these, http://www.binnys.com/beer/Bud_Light...num_40500.html
__________________
Michael Hill, "Ghostrider"
1980 KZ-1000 ST-MKII, "Baby Doll"
72 Chevy C/10 SS-396 w/Comp Cam=268H, Closed Chamber 290 heads, Stage-4 Power Pack (Eagle Red's) 350THM, Beefed up 12-Bolt, Eaton 4:56 Posi, (Diesel Killer) Street Rod LWB "Nasty Sally"
72 Chevy C/10 Rebuilt 350 w/Voodoo-10120701 Cam, Stage-4 350THM, Beefed up 12-Bolt 3:73 Eaton Posi, LWB Wood Bed, (Daily driver, work horse) "Belle"
https://www.facebook.com/michael.hill.12979
https://www.facebook.com/kz1000rider/
Ironangel is offline   Reply With Quote