View Single Post
Old 05-22-2020, 10:23 AM   #1
special-K
Special Order
 
special-K's Avatar
 
Join Date: Nov 2004
Location: West Falls, MD
Posts: 73,430
Lost R/L/HAZ/BRK/REV Lights

This is with my '95 K2500 Suburban Cheyenne. First I noticed the turn signals were not flashing, nothing. I check the 4-ways, nope. I backed up in the dark and noticed no reverse lights or brake lights. All running lights work as well as headlights. I replaced the flasher relay, no change. I guess I have a ground issue but wondering if anyone has any suggestions. I don't get how the backup lights fit in. I'd suspect a grounding or wire issue toward the rear just from experience with aging vehicles, rust, mud hanging, snagging... But my hunch is it is up front closer to controls. I really don't know and electrical is my weakest area.

Fuses all look good. Not much there, only 5 lower amp with none marked for lights, other than the 30a maxi. No brake light relay and no blades for fuse in spot marked HAZ/BRK. I can get a picture of the fuses and chart in cover and post this evening. I need to get this fixed this weekend!

My wipers have been acting up, for a while. They'll go to low off intermittent or might not turn off right away. I figure I need the wiper module. But could an issue in the stick have some effect on my signal/brake lights?
__________________
"BUILDING A BETTER WAY TO SERVE THE USA"......67/72......"The New Breed" GMC

'67 C1500 Wideside Super Custom SWB: 327/M22/3.42 posi..........'The 67' (project)
'72 K2500 Wideside Sierra Custom Camper: 350/TH350/4.10 Power-Lok...'The 72' (rolling)
Tim

"Don't call me a redneck. I'm a rough cut country gentleman"

R.I.P. ~ East Side Low Life ~ El Jay ~ 72BLUZ ~ Fasteddie69 ~ Ron586
special-K is online now   Reply With Quote