View Single Post
Old 10-27-2017, 09:13 PM   #162
Palf70Step
State of Confusion!

 
Palf70Step's Avatar
 
Join Date: Jul 2002
Location: Gulfport, MS USA
Posts: 38,138
Re: 1965 C10 ... Project Name: Just Learnin'

Quote:
Originally Posted by Alberta65 View Post
Ok, now if anyone is still paying attention I have a couple questions to throw out to the crowd and see if anyone can help me out here...

1. The Classic Sound (or whatever its called) radio I installed is doing some funky stuff. When the ignition is in the on position, the radio works great, all six speakers play and the radio has good reception. BUT when i actually turn the truck on, then the radio is very choppy... This has confused me greatly and I've checked all grounds and everything I have in my limited knowledge of car audio and can't figure it out.

2. Now the second one is an air ride question... I have noticed in order to level the truck out I'm running about 30psi in the back and 70 psi in the front..... If I run the same pressure front and rear the truck has a nasty rake! I may be a child of the 90s but this chevy isn't.. no rake wanted here. So I mounted the bags in the stock location of the rear springs but I still feel like it should be able to sit lower with the frame notch...


ANY ADVICE?!?!
For ur #1, I had the same issue when I went to a non_GM HEI. I ended up installing a noise suppressor. That seemed to take care of all my issues
This is what I used

https://www.amazon.com/BOSS-Audio-B1.../dp/B000FKP7MG
Attached Images
 
__________________
Bill

1981 GMC High Sierra SWB Stepside

"Whitey" 2002 Chevy Silverado 1500 SWB W/T
Member of Louisiana Classic Truck Club (LCTC)
Board Vendors
Bill's Gallery
Life isn't tied with a bow, but it's still a gift.
Live simply. Love generously. Care deeply. Speak kindly. Leave the rest to God!
It's scary when you start making the same noises as your coffee maker.
Palf70Step is offline   Reply With Quote