The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 10-05-2015, 09:15 PM   #1
jks67ss396
Registered User
 
Join Date: Nov 2012
Location: So Cal
Posts: 294
no brake lights, but the turn signal and tails lights work

Guys,

I lost my brake lights today. The tail lights work. The turn signals work. and they flash. But no brake lights.

I have power at my orange wire on going to the brake light switch under the dash.

I was under the assumption that if i have turn signals, id have brake lights and vice versa, but evidently not.


Any ideas?
jks67ss396 is offline   Reply With Quote
Old 10-05-2015, 09:30 PM   #2
VetteVet
Msgt USAF Ret
 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,178
Re: no brake lights, but the turn signal and tails lights work

Check the white wire from the brake light switch to the half moon connector for power on both sides of the connector. It carries power for the brake lights into the turn signal switch
__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Old 10-05-2015, 09:53 PM   #3
jks67ss396
Registered User
 
Join Date: Nov 2012
Location: So Cal
Posts: 294
Re: no brake lights, but the turn signal and tails lights work

its dark out, but ill try to check.

the turn signals do work. so is there a separate output path for the brake lights vs turn signals?
jks67ss396 is offline   Reply With Quote
Old 10-05-2015, 11:52 PM   #4
chevyguyase
Registered User
 
Join Date: Aug 2015
Location: st charles missouri
Posts: 137
Re: no brake lights, but the turn signal and tails lights work

check your hazard switch if you have one, it may be half way on or off.
chevyguyase is offline   Reply With Quote
Old 10-06-2015, 08:30 AM   #5
VetteVet
Msgt USAF Ret
 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,178
Re: no brake lights, but the turn signal and tails lights work

Quote:
Originally Posted by jks67ss396 View Post
its dark out, but ill try to check.

the turn signals do work. so is there a separate output path for the brake lights vs turn signals?
Yes there are two sets of contact points in the turn signal switch for each turn/brake wire. When the switch is in no turn, the white wire feeds both contact points for the yellow and dark green wires. When either turn is selected the points are switched for that side, and the brake is disconnected so the turn light can flash.

Don't forget to press the brake for the white wire power test.
__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Old 10-06-2015, 10:44 AM   #6
jks67ss396
Registered User
 
Join Date: Nov 2012
Location: So Cal
Posts: 294
Re: no brake lights, but the turn signal and tails lights work

ok, i think I at least diagnosed the problem

I do get 12V at white wire when brakes are pressed.

I do get flashing voltage (12V, then 0, then 12) on green and yellow (and blue and light blue) when i use the turn signal. green/yellow wires are rear taillights, blue/light blue are front blinker lights.

I do get same voltage when the hazzard is turned on.

But, I dont get voltage on the green or yellow wire when just the brakes are pressed and no turn signal

So, Im going to pull the steering wheel and see what i can see on the mechanics of the switch.

Just curious if you know this one:

Ive got a tilt column from an 80s motorhome. its got the flat connector (and theres an adapter to take the flat connector to horseshoe) and it has a black hazzard push/pull lever.

If i need to replace the turn signal switch, can i use the "correct" one for a 71 C10 with tilt? Or do i have to go get the motor home one? I would imagine i could handle the wiring, but its the hazzard button im not sure of.

Any ideas?

thanks guys!! youve been a huge help!!!
jks67ss396 is offline   Reply With Quote
Old 10-06-2015, 01:15 PM   #7
VetteVet
Msgt USAF Ret
 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,178
Re: no brake lights, but the turn signal and tails lights work

With different columns you are most likely going to have to use the one that's installed.
If you check the part no.s and they match, the same switch should fit both.
__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Old 10-06-2015, 02:13 PM   #8
jks67ss396
Registered User
 
Join Date: Nov 2012
Location: So Cal
Posts: 294
Re: no brake lights, but the turn signal and tails lights work

well, i was able to pull the wheel and study the switch. i love that kind of ingenuity

i disassembled the switch, cleaned the contacts, reassembled the switch, but didnt reinstall. and thought for sure, ill have brakes. nope...

looks like i have a break in the white wire. i measure 12V on both sides of the connector, but i dont get 12V up at the contact on the switch.

I might need a couple of new terminals. Do you guys happen to know the part number for those terminals that fit the horse shoe and the flat->horseshoe adapter?

thanks
jks67ss396 is offline   Reply With Quote
Old 12-23-2017, 06:41 PM   #9
elf w/capital T
Registered User
 
Join Date: Feb 2011
Location: North Carolina
Posts: 964
Re: no brake lights, but the turn signal and tails lights work

Jks, ever get this issue solved? Bad ground?
elf w/capital T is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com