The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-21-2011, 12:35 PM   #1
cochino12
It followed me home?
 
cochino12's Avatar
 
Join Date: Mar 2003
Location: Parker, Co
Posts: 5,745
Trailer brake problem, please help!!!

I friggin hate trailer brakes!!! ok here is my issue. First off I dont have a ohm/voltmeter here so that isnt helping. However, I do have a +12v test light which shows power coming through the trucks trailer plug, power going to each brake, and can hear the brakes humming when I hit the brake or slide the manual brake on the controller. When I use the slide on the controller the +12v light does get brighter but brakes wont engage.

I have adjusted the brakes several times and I'm pretty sure thats not the issue. Just to be positive I tightened them all the way down and the still wont engage with the truck.

What am I missing?
__________________
Adam

That's why they call it a shortcut Kyle, if it was easy it would just be the way.

86 c-10 SWB
85 CCSB
90 GMC K30 Crew SRW
1985 C30 Dually
cochino12 is offline   Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com