The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 03-30-2017, 01:44 PM   #1
65chevysub
Registered User
 
65chevysub's Avatar
 
Join Date: Feb 2013
Location: Cottonwood, Arizona
Posts: 811
Brights quit working

I have a question. I went to use my brights last week and when I pressed on the dimmer switch, my lights went out. Stepped on it again and lows came back on. Could it be a bad switch? I have it bolted to the floor as the original nuts are stripped.
Thanks
65chevysub is offline   Reply With Quote
Old 03-30-2017, 03:36 PM   #2
Moose Monkey
Registered User
 
Moose Monkey's Avatar
 
Join Date: Sep 2016
Location: south jersey
Posts: 42
Re: Brights quit working

Three connection's two live with light switch on. Push switch one goes dead other goes live high then lows if not replace dimmer switch
Moose Monkey is offline   Reply With Quote
Old 03-31-2017, 12:11 AM   #3
El Dorado Jim
Registered User
 
Join Date: Dec 2009
Location: El Dorado Ca
Posts: 1,619
Re: Brights quit working

yep, sounds like your dimmer switch is bad
El Dorado Jim is offline   Reply With Quote
Old 03-31-2017, 06:17 PM   #4
65chevysub
Registered User
 
65chevysub's Avatar
 
Join Date: Feb 2013
Location: Cottonwood, Arizona
Posts: 811
Re: Brights quit working

Ok. I just replaced the dimmer switch and still have the same problem.
It started when I hooked up the hazard lights in my steering column. I have a tilt unit from a 72 and got the flashers working, but now no brights. Before the flashers, I wired the front park lights so they would stay on with headlights. Now they go off like original.
65chevysub is offline   Reply With Quote
Old 03-31-2017, 08:46 PM   #5
franken
Registered User
 
Join Date: Jun 2013
Location: Somewhere
Posts: 1,801
Re: Brights quit working

The floor dimmer switch contacts get dirty and you have to cycle the switch a bunch of times to clean the contacts. I just click it w/ my foot about 10 times and things start to work... Lots of dimmer switched get replaced because of this. New switches may have the same issue w/ some sort og goo used during manufacturing--in fact I think that's how I figured it out originally--cycling the switch in frustration after the new one didn't work, then testing the old one the same way. Sometimes it works out being a dumbass...
The switch is in a location where it tends to get wet and F-ed up, but if you replaced it, things are probably clean.
Of course if you did something else right before, that may not be the trouble.

Last edited by franken; 03-31-2017 at 08:51 PM.
franken is offline   Reply With Quote
Old 03-31-2017, 09:11 PM   #6
65chevysub
Registered User
 
65chevysub's Avatar
 
Join Date: Feb 2013
Location: Cottonwood, Arizona
Posts: 811
Re: Brights quit working

Thanks Franken. I will "cycle" the switch a few timed to see what happens. Then if that dont work I will unhook the E flashers and stsrt again
65chevysub is offline   Reply With Quote
Old 04-01-2017, 09:37 AM   #7
Moose Monkey
Registered User
 
Moose Monkey's Avatar
 
Join Date: Sep 2016
Location: south jersey
Posts: 42
Re: Brights quit working

Did you check voltage at dimmer? Sounds like you're having more than one problem at once.go at dimmer switch first, get them back to working and then the others .
Moose Monkey is offline   Reply With Quote
Old 04-01-2017, 11:41 PM   #8
t300
Registered User
 
Join Date: Mar 2013
Location: Manitoba
Posts: 141
Re: Brights quit working

My brights went out, turned out the plug on the dimmer had melted over the years and the metal spades inside were no longer making contact to the dimmer. tweaking the plug works for a while but the real fix will be to replace the plug end (and add some relays so it doesn't happen again)
t300 is offline   Reply With Quote
Old 04-04-2017, 01:23 PM   #9
65chevysub
Registered User
 
65chevysub's Avatar
 
Join Date: Feb 2013
Location: Cottonwood, Arizona
Posts: 811
Re: Brights quit working

I did what franken recommended by "cycling" the switch several times and it worked. Everything is back to normal now.
Thanks to all your help and tips
65chevysub is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com