The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 03-25-2017, 09:26 AM   #1
Ewr101
Registered User
 
Ewr101's Avatar
 
Join Date: Dec 2014
Location: Spring, Tx
Posts: 202
Wow!

Bought the Blazer over two years ago. The first thing I did was go thru the wiring to get various lights and gauges to work properly. This included rewiring/upgrading the whole charging system. The truck has ran just fine the whole time (Or so I thought). Since I didn't know when the last tune up was, I figured I'd change out the whole HEI, plugs and wires. This is what I found after removing the old HEI distributor. That can't be good! Haha! Gonna finish up making the wires and timing it today and we'll see how she runs....
Attached Images
 
__________________
72 Chevy 2WD Blazer
Ewr101 is offline   Reply With Quote
Old 03-25-2017, 07:30 PM   #2
Moose Monkey
Junior Member
 
Moose Monkey's Avatar
 
Join Date: Sep 2016
Location: south jersey
Posts: 72
Re: Wow!

Is that the ground wire? Check those main ground cables please. WOW way well put.
Moose Monkey is offline   Reply With Quote
Old 03-25-2017, 08:23 PM   #3
Ewr101
Registered User
 
Ewr101's Avatar
 
Join Date: Dec 2014
Location: Spring, Tx
Posts: 202
Re: Wow!

Yep, that's the ground. It was pretty well done for. The power and the other one were shot as well, just not as bad. Was hoping I would have a new motor after changing everything! Haha!! It ran pretty smooth and was more responsive and for its age, so I'll take it! I guess in hindsight, I can't believe it ran as well as it did! There were no signs that the wiring was like that. No cutting out, no rough idle, no nothing. I was shocked! I believe I got it timed correctly so we'll see. I'm just glad to be rid of more bad wiring....and the fire hazard.

P.S.- while "Dragonfire 10.5mm" spark plug wires seem to be a good deal, they aren't worth the hassle of building them. They seem to work fine but the larger outside diameter make putting connectors on a P.I.T.A. Not so sure about the center conductor being any bigger or better. I'll save up for some good Accel or MDS 8.5's or 9mm ones when I feel the need.
__________________
72 Chevy 2WD Blazer
Ewr101 is offline   Reply With Quote
Old 03-25-2017, 08:30 PM   #4
Moose Monkey
Junior Member
 
Moose Monkey's Avatar
 
Join Date: Sep 2016
Location: south jersey
Posts: 72
Re: Wow!

You are just too lucky. Me, would not find that for weeks
Moose Monkey is offline   Reply With Quote
Old 03-25-2017, 08:37 PM   #5
Ewr101
Registered User
 
Ewr101's Avatar
 
Join Date: Dec 2014
Location: Spring, Tx
Posts: 202
Re: Wow!

I guess you could call it luck. I've had it for 2 years and it ran just fine. I just replaced the HEI and wires cause I didn't know when it was done last. I expected worn but not THAT! One of the spark plug wires had the outer jacket gouged too. Amazing it ran like it did. There was absolutely no signs of the wiring being like that.
__________________
72 Chevy 2WD Blazer
Ewr101 is offline   Reply With Quote
Old 04-20-2017, 09:22 PM   #6
Ewr101
Registered User
 
Ewr101's Avatar
 
Join Date: Dec 2014
Location: Spring, Tx
Posts: 202
Re: Wow!

After getting everything swapped out, setting the timing, replacing a packard connector in the engine side fuse block to get power to the choke and adjusting it along with the high idle, I've got an engine that runs really well. I was shocked when it actually broke the rear tires loose under acceleration and gave me a little chirp going into second gear.

Shout out to VetteVet, GMACHINZ and TBONE for all their help in getting me to this point. THANK YOU! It's FAR from finished but so much better than when I first got it. This site is an awesome resource for knowledge and info. Can't wait for the next project...electric fans....rear side panels....homemade center console....new grille....slight drop and sway bars....hmmm....descisions descisions....
__________________
72 Chevy 2WD Blazer
Ewr101 is offline   Reply With Quote
Old 04-20-2017, 11:48 PM   #7
El Dorado Jim
Registered User
 
Join Date: Dec 2009
Location: El Dorado Ca
Posts: 1,786
Re: Wow!

those wires are UGLEE!
El Dorado Jim is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com