The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1969 - 1972 Blazers and Jimmys Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 04-08-2021, 11:40 AM   #1
jaxncurtis
Registered User
 
Join Date: May 2017
Location: Gilbert, AZ
Posts: 32
Fresh New Engine - Need help trouble shooting

Hey guys, I just installed a fresh new 250 inline 6 engine. Started it this last week and did the first breakin and was able to get the timing set pretty much perfect. She runs GREAT!!

I never put it in gear to drive it... up until today...

I put it in gear and the truck will not go any faster than 5mph with the pedal to the floor!!

What could be the issue here? Do I have the kickdown cable two loose? Too tight? Anything else you can think of?

Im certain nothing is wrong with engine as it is running great!

Im new to installing engines so please bare with a newbie...
jaxncurtis is offline   Reply With Quote
Old 04-08-2021, 12:34 PM   #2
kwmech
Senior Member
 
Join Date: Mar 2003
Location: Colfax-California
Posts: 6,510
Re: Fresh New Engine - Need help trouble shooting

Left the parking brake on? plugged exhaust?
kwmech is offline   Reply With Quote
Old 04-08-2021, 12:43 PM   #3
jaxncurtis
Registered User
 
Join Date: May 2017
Location: Gilbert, AZ
Posts: 32
Re: Fresh New Engine - Need help trouble shooting

I check parking break that is off... Rolled down drive way with no problem...

No exhaust, just headers at the moment. Was on the way to go get mufflers!!!
jaxncurtis is offline   Reply With Quote
Old 04-08-2021, 02:14 PM   #4
SeventyOne
Registered User
 
Join Date: Mar 2007
Location: Berkeley, Ca
Posts: 1,303
Re: Fresh New Engine - Need help trouble shooting

Do you have fluid in the trans?
SeventyOne is offline   Reply With Quote
Old 04-08-2021, 07:08 PM   #5
1rippen6
Senior Member
 
Join Date: May 2011
Location: Greencastle PA
Posts: 6,099
Re: Fresh New Engine - Need help trouble shooting

If the converted slide out and you didn't reseat it, it's possible that you jammed it into the pump. Ask me how I know, experience from my first tranny install years ago.
1rippen6 is offline   Reply With Quote
Old 04-09-2021, 09:08 AM   #6
litebulblsc
Registered User
 
litebulblsc's Avatar
 
Join Date: Aug 2006
Location: LaSalle Mi
Posts: 382
Re: Fresh New Engine - Need help trouble shooting

What does it do when you give it more gas- does the engine speed up or stay flat?

It sounds like it is an automatic transmission. If it is a TH350, it will operate without the kick down cable. I doubt its adjustment is your issue, but you can disconect it temporarily to eliminate the possibility.

But at this point, I would advise against trying too much without verifying it is not something more serious first.

The more info and any pictures you can post could possibly help to figure out the issue.
litebulblsc is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:55 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com