The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board > Squarebody Projects and Builds

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 04-23-2017, 08:36 PM   #201
Shucks
Registered User
 
Shucks's Avatar
 
Join Date: Nov 2013
Location: Lawrence Kansas
Posts: 184
Re: Project "You thought yours was bad!" '78 C10 Stepside

Looks real good! Can't wait to hear how the EFI works
__________________
C H E V R O L E T

Check out my build thread!
Shucks First Build
Shucks is online now   Reply With Quote
Old 04-25-2017, 12:46 AM   #202
Nick_R_23
Registered User
 
Nick_R_23's Avatar
 
Join Date: May 2016
Location: Willow, Alaska
Posts: 336
Re: Project "You thought yours was bad!" '78 C10 Stepside

Thanks! I'm excited too, it's taking too long at this final part!

So I got my driveshaft in today thinking that this was the final piece of the puzzle, that I could bolt it in, top off the trans, and fire it up. But when I went to mount the driveshaft to the axle, I couldn't get it to slide forward enough to come even close to getting the U-joint to make with the axle - the driveshaft was made too long! I called the shop and we verified that the specs and measurements given were correct, so I'm not sure what happened. But, they are willing to fix it for me if I drop it back off, so I'll be happy with that! I think between 3/4" to 1" shorter would be perfect. Unfortunately, with the time from dropping it off and picking it back up may leave me with limited time to actually mount and then be able to test fire this thing before I leave on my trip. Hopefully I can, but if not, I will have to leave you all as well as myself in suspense for two weeks!



Here is the yoke fully bottomed out in the transmission (note the mark)



And here is the yoke laid near the transmission with the U-joint seated in the axle (note mark again). There is some free area, but it is maybe 3/16" at most. Not good.



And here is the yoke bottomed out in the transmission, then pulled out 1" at proper free length setting. The U-joint sits almost perfectly 1" further back from the rear axle yoke.



I will be dropping this off extremely early Wednesday morning in hopes that this will be done in time before I go!
__________________
Check out my Alaska built 78/86 C10 stepside! http://67-72chevytrucks.com/vboard/s...d.php?t=706825
Nick_R_23 is offline   Reply With Quote
Old 04-28-2017, 05:43 AM   #203
Nick_R_23
Registered User
 
Nick_R_23's Avatar
 
Join Date: May 2016
Location: Willow, Alaska
Posts: 336
Re: Project "You thought yours was bad!" '78 C10 Stepside

I'll just leave this here

Video of it running! https://www.youtube.com/watch?v=-yWL7IucV2E

__________________
Check out my Alaska built 78/86 C10 stepside! http://67-72chevytrucks.com/vboard/s...d.php?t=706825
Nick_R_23 is offline   Reply With Quote
Old 04-28-2017, 12:15 PM   #204
Nick_R_23
Registered User
 
Nick_R_23's Avatar
 
Join Date: May 2016
Location: Willow, Alaska
Posts: 336
Re: Project "You thought yours was bad!" '78 C10 Stepside

Woohoo, so everything last night went pretty smoothly. Picked up my driveshaft, fit great this time. Topped off the trans, installed my new battery hold down clamp, primed the fuel pump a few times, hit the key and she fired right up without even a hint of hesitation! I let it run for about 15 minutes up to temp while keeping an eye on the trans fluid level. While I didn't get to drive it, the trans engaged into all gears and felt solid. The exhaust sounds great! It has a nice rumble and while it is obviously far from stock, is thankfully just quiet enough where it shouldn't wear on me during long drives.

I've unfortunately ran out of time before my 2 week trip down to Texas, as I'm leaving right after work tonight. But there's minimal things left to do to drive her! I still need to set the timing and phase the rotor, pick up an air filter, the air cleaner looks like it'll barely clear the linkage so I'll be picking up a 1" spacer for safety. Other than that, I just need to renew the registration and take it on a drive! Please check out the running video, I'll be trying to get a driving and maybe a walk around video here in the coming weeks!
__________________
Check out my Alaska built 78/86 C10 stepside! http://67-72chevytrucks.com/vboard/s...d.php?t=706825
Nick_R_23 is offline   Reply With Quote
Old 04-28-2017, 08:41 PM   #205
rusty76
Registered User
 
rusty76's Avatar
 
Join Date: Sep 2012
Location: Midway, NC
Posts: 2,678
Re: Project "You thought yours was bad!" '78 C10 Stepside

Glad to see things working out. Have a safe trip.
__________________
http://67-72chevytrucks.com/vboard/s...d.php?t=581873
The low buck build threads. Check'em out!
http://67-72chevytrucks.com/vboard/s...d.php?t=666022
My build thread
Crossmembers CC
rusty76 is offline   Reply With Quote
Old 04-28-2017, 11:57 PM   #206
Nick_R_23
Registered User
 
Nick_R_23's Avatar
 
Join Date: May 2016
Location: Willow, Alaska
Posts: 336
Re: Project "You thought yours was bad!" '78 C10 Stepside

Thank you! I'll keep you guys updated. Any more thoughts on the build so far, good or bad are appreciated!
__________________
Check out my Alaska built 78/86 C10 stepside! http://67-72chevytrucks.com/vboard/s...d.php?t=706825
Nick_R_23 is offline   Reply With Quote
Old 05-01-2017, 02:54 AM   #207
Smniekamp
Registered User
 
Smniekamp's Avatar
 
Join Date: Jan 2017
Location: Palmer, Alaska
Posts: 53
Re: Project "You thought yours was bad!" '78 C10 Stepside

She's sounding good man! I'm digging that last video!
Smniekamp is offline   Reply With Quote
Old 05-15-2017, 09:03 PM   #208
Nick_R_23
Registered User
 
Nick_R_23's Avatar
 
Join Date: May 2016
Location: Willow, Alaska
Posts: 336
Re: Project "You thought yours was bad!" '78 C10 Stepside

Thanks man!

Alright, I'm finally back from my Texas trip! That was a ton of fun, but I was dying to get back to my truck the entire time. Today was my only day before I go back to work tomorrow, so I got the last little bit done, got new tags and insurance and took her out on the road!

I had to go to town and pick up a new timing light as the old Sun timing gun died. It was older than I was! This one seemed to work well for a basic model.



I set the timing on the engine to match the targeted timing on the Sniper handheld, then went to work changing out the distributor cap to phase the rotor. You can also see the plastic intake spacer I picked up. The metal one I got didn't work at all, this one works but is pretty cheesy. I think I'll just end up making my own at some point.



The other new cap modified. Turns out it was nearly impossible to see here, so I ended up with another hole on the top.



I also picked up a new air filter and stuck the dual snorkel air cleaner on! I love the stockish but stealthy look it gives the engine bay. I'll take it back off and paint it when I make a new spacer.



Double checked all the fluids and backed it outside for the first time! My coolant sensor was leaking, I must have forgotten to torque it down the rest of the way. Tightened it back down and everything was fine!



Whoops.



And here's the first drive! Stopped over and visited a friend who has this pre-47 Chevy. It has an LS1, T56, 4 link rear end, and 15x8/15x10 wheels. It's fast!





Overall I'm pretty happy with the truck! There's still a handful of bugs and little things I want to finish on it. I did notice that on a hard turn, my wheels barely rubbed the control arms, so I'll be going back under to do a little clearancing there. It drives straight down the road but I'll take it in for an alignment just to be safe. One or both of the idler pulleys on the accessory drive needs to be replaced, it squeaks a bit.

The one big issue I was having is that I seem to be getting some detonation/spark knock when I get into the throttle a bit trying to accelerate on the highway. Just starting off, up to about 15%+ throttle it is fine. If I try and get into the throttle quickly about 20% or more, it rattles and acts like the engine lugs. If I shift out of OD into D, it revs the engine right back up and doesn't rattle anymore, but if I stop and start moving again, even in D the rattle can come back. If I ease through the throttle I won't get the knock, it just seems to be right when it gets into load. The Overdrive seems like it needs some tuning as well, I'm not sure what I'll need to do yet, but it seems to shift in a little early at times. I'd basically rather keep it out of OD until I'm cruising. I'm running 32* timing but I'm going to check with Holley to see if there's some addition ignition tuning I can do. For now though, I'm happy to have been able to drive it after this much time! It's gotten tons of looks even just the few miles I put on it!
__________________
Check out my Alaska built 78/86 C10 stepside! http://67-72chevytrucks.com/vboard/s...d.php?t=706825
Nick_R_23 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com