The 1947 - Present Chevrolet & GMC Truck Message Board Network

Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 99-06 Chevy and GMC Message Board


Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-14-2016, 10:26 PM   #1
Registered User
Join Date: Jun 2006
Location: massachusetts
Posts: 107
2003 head issue

I've waited a while before posting to make sure i wasn't jumping the gun, I've had the dreaded coolant leak into the oil for a few years now and my way of dealing with it was to frequently change the oil. months ago I put in the ac delco coolant seal tabs and to my surprise I didn't lose any coolant for months and let it go a while longer and still no coolant loss. So considering that I also had a bad engine tick i removed the valve covers and witnessed a terrible mass of gunk all over everything I cleaned it out and replaced the badly worn push rods and after putting it back together no ticks the oil pressure gauge is extremely responsive to the throttle and still no coolant loss. i might have saved my baby. I have the casteck 706 heads and 100% think I have the bad ones I was concerned about the tablets but I mixed them up in water before I put them in and It looked rather benign to me so i put 4 tabs in and my heat still works so It didn't screw up the heater core yet.
pamoffa is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -4. The time now is 03:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 1997-2013