The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 11-13-2017, 03:26 AM   #1
jlpark
Registered User
 
Join Date: Nov 2017
Location: fairbanks alaska
Posts: 2
83 k20 plow truck not charging

I just got a K20 plow truck with a diesel 6.2. What does it mean if the red wire on the back of the alternator is putting out 14.7 volts but it isn't reaching the battery?

Also the truck has several other electrical issues in case they are related: Headlights intermittent; temp, oil, and alt gauges not working.

I greatly appreciate any help.

Jeff
jlpark is offline   Reply With Quote
Old 11-15-2017, 03:26 AM   #2
Feel the 'Pane
Registered User
 
Join Date: May 2017
Location: Central city
Posts: 8
Re: 83 k20 plow truck not charging

Hi Jeff,

All gauges on dash not working sounds like a blown fuse.

If the alt is putting out 14.7v, try testing for juice @ the electrical junction up on the firewall while the engine is running. There's a fuseable link that might be bad or just needs a little bulb grease to make a good connection.

Same thing happended to me lately. I had just rebuilt my alt. & a week later it stopped charging the batteries but still put out 14.7vt. After some digging, I found an aluminium butt connector hiding in the line (behind the engine), going from the starter, up to the fuseable link on the firewall. It was poorly crimped & had melted from the 96 amps the new alt was putting out. (A winch draws alotta amps!)


Same goes for the headlights. If they're going out (or flickering) at the same time, either a dirty/bad fuse, a weak ground, or possibly a poor connection @ the headlight switch under the dash.

When I'm tracking down electrical issues, I always start with the easiest fixes first.

Hope the above helps...

FtP
Feel the 'Pane is offline   Reply With Quote
Old 11-15-2017, 04:30 AM   #3
jlpark
Registered User
 
Join Date: Nov 2017
Location: fairbanks alaska
Posts: 2
Re: 83 k20 plow truck not charging

That helps quite a bit. Thank you!

Looks like i'll be learning about fusible links this weekend.
jlpark is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com