The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 05-13-2019, 01:03 PM   #1
Minkota
Registered User
 
Join Date: Jun 2016
Location: West Palm Beach, Florida
Posts: 58
67 Stepside Front Park/Turn Signals not working

I have a 67 C10 Stepside and all the Lights see to work with the exception of the Front Park/Turn Signal Lights. Is there a Wiring Schematic here on the forum I can view to diagnose the issue?
Minkota is offline   Reply With Quote
Old 05-14-2019, 05:32 PM   #2
First c10
Senior Member
 
First c10's Avatar
 
Join Date: Dec 2012
Location: Los Banos CA
Posts: 2,396
Re: 67 Stepside Front Park/Turn Signals not working

The first sticky above your post!

http://67-72chevytrucks.com/vboard/s...d.php?t=185856
__________________
1956 Chevy Bel Air 2 door
1956 Chevy 210 4 Door
1970 K20 LWB project the Hulk build w/4.8L-ly4/4L60E HULK BUILD
1970 C10 Yellow/White Deluxe LWB w/ 5.3L-LC9/6L80E
1968 K10 LWB Dark green my son calls it "THE HULK Jr"HULK JR *SOLD*
GO GO!!!
First c10 is offline   Reply With Quote
Old 05-17-2019, 05:14 PM   #3
'68OrangeSunshine
Senior Member
 
'68OrangeSunshine's Avatar
 
Join Date: Feb 2002
Location: Tucson, AZ USA
Posts: 4,613
Re: 67 Stepside Front Park/Turn Signals not working

For the 1967 Model Year that is normal. The Parking Lights come on with the first click of the Headlight Switch, and go off with the second click for the big Headlights. [Unless I misread your question, and the front Parking lights are totally dead at all times.]*
They should blink as directional signals when indicating a Left or Right turn by selecting the turn signal lever up or down. They should both blink in unison on Hazard by depressing the button on the Column.

I drove a '68 C/10 Stepside for 20 years before I bought a '67 K/10 Suburban. I thought something was wrong with the wiring until I saw an Orange Stepside much like my own '68, but a '67 [no side markers] outside a bar. Being one of my former undergraduate hangouts, I inquired inside, and it was the bartender's truck. Over a beer, I explained my '67 Sub's ''gripe'' and he said that's how it was for that year. We went out to the parking lot, and sure enough, his stepside had no yellow "Running Lights" when the Headlight Switch went to 2nd click. And that was normal. This was before the internet, obviously.

In 1968, Federal regulations mandated they become Running Lights, and stay on with the headlights. Also Side Marker Reflectors were mandated. '69 MY, the Side Markers were optionally illuminated, and by '71 MY they were illuminated as Standard, and the front side markers blinked alternately with the front Running Lights when indicating turns.

* If you have totally dead lights, it could be the bulbs, corrosion inside the bulb sockets, opens in the wiring to the light buckets, bad grounds, or any-and-all of the above.
__________________


Every 25 years I like to rebuild that 292, whether it needs it or not.

Last edited by '68OrangeSunshine; 05-17-2019 at 05:39 PM.
'68OrangeSunshine is online now   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:12 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com