The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 12-31-2018, 09:09 PM   #1
Lostatsea
Registered User
 
Join Date: Aug 2018
Location: Houston tx
Posts: 3
New harness problems

Just finished American auto wire complete harness on my 67 c10. Only thing that works are headlights/high beams and the engine will turn over. Nothing else is working or has power. Iím really discouraged and overwhelmed on where to even start. Any ideas? Thanks guys
Lostatsea is offline   Reply With Quote
Old 12-31-2018, 09:33 PM   #2
Lostatsea
Registered User
 
Join Date: Aug 2018
Location: Houston tx
Posts: 3
Re: New harness problems

Found the first foolish mistake. Did not have any of the fuses installed. I now have turn signals. Still nothing on the dash cluster. Does the connector that plugs into dash cluster only go one way?
Lostatsea is offline   Reply With Quote
Old 01-10-2019, 06:37 PM   #3
notsolo
Senior Member
 
notsolo's Avatar
 
Join Date: Apr 2008
Location: Md
Posts: 1,701
Re: New harness problems

I believe the dash cluster plug is 1 way, on mine...72...classic update...harness dash wiring is slightly different for oil pressure vs just lights..Different pages on the instruction sheet...check all your grounds, make sure you have solid clean contact for Frame, cab, front and back sheet metal....should also be a ground clip for dash bezel....also .Welcome aboard.
notsolo is offline   Reply With Quote
Old 01-10-2019, 09:17 PM   #4
04ls1gto
Registered User
 
Join Date: Aug 2014
Location: Portsmouth ri
Posts: 304
Re: New harness problems

Grab a test light and start checking things. You'll figure it out
04ls1gto is offline   Reply With Quote
Old 01-11-2019, 02:33 AM   #5
First c10
Senior Member
 
First c10's Avatar
 
Join Date: Dec 2012
Location: Los Banos CA
Posts: 2,440
Re: New harness problems

I am days away from starting my install. I hope you figure it out. For me it’s always a simple little thing I over looked.
__________________
1956 Chevy Bel Air 2 door
1956 Chevy 210 4 Door
1970 K20 LWB project the Hulk build w/4.8L-ly4/4L60E HULK BUILD
1970 C10 Yellow/White Deluxe LWB w/ 5.3L-LC9/6L80E
1968 K10 LWB Dark green my son calls it "THE HULK Jr"HULK JR *SOLD*
GO GO!!!
First c10 is online now   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:07 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com