The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1988 - 1998 Chevy & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 08-20-2017, 11:06 PM   #1
Jeffdoss
Registered User
 
Join Date: Aug 2017
Location: Danville
Posts: 4
1990 k1500 engine problems

Put a motor in my truck everything was fine for a few days then it started to hesitate while giving it gas then it started idleing really bad sounded like it has a huge cam in it plugged it up showed tps sensor changed it and the temperature sensor was fine for about a day now it doesn't hesitate when giving it gas but still idleing really funny most of the time and then If u take off it goes through 1-3 fine but when it hits drive it kinda just jumps in overdrive and feels like it has no power but shifting through each gear manually it's fine all power is there in every gear so don't think it's tranny related just believe it's from the other issues would love any ideas to try before I drive it to the junkyard and crush it myself
Posted via Mobile Device
Jeffdoss is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com