The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > S10 S15 Luv Blazer II

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 06-30-2017, 08:25 PM   #1
61_FL_Apache
Who Me?
 
61_FL_Apache's Avatar
 
Join Date: Sep 2010
Location: Royal Palm Beach, FL
Posts: 3,461
01 Blazer Gas Gauge Issue

My daughters Blazer started having gas gauge issues. The gauge seems to have a mind of its own. It will read correctly half the time and show empty the other half. When the needle is on Empty, the low fuel light will also be on. So those seem to be working together.

There are no CEL's for this issue. I have a P0650 which indicates an issue with the CEL.. go figure. I suspect the sending unit in the tank, but wanted to get your feedback.

Thanks for your help!
__________________
Steve
61_FL_Apache is offline   Reply With Quote
Old 07-04-2017, 11:13 AM   #2
midniteblues
Registered User
 
midniteblues's Avatar
 
Join Date: Jul 2011
Location: strausstown pa
Posts: 3,283
Re: 01 Blazer Gas Gauge Issue

From my experience.

If the pump is the oe pump then it may be on its way out,the sending unit getting sloppy and giving wack readings is a early indicator of it.

If the pump and module have been replaced then it's normal for the sending unit not too work
Aftermarket modules the sending unit part don't seem to last or work very long.
It seems the piviot point for the float gets real sloppy in short time and the two halves of the rheostat loses contact with each other. Some bounce around on the pivot with sloshing gas and that's why you get a bouncy needle.

From what I have read online.
If your pump goes out its best to just replace the motor and not the whole module,as the oe modules have a much better fit on the pivot point on the body. Some lose contact over time some dont.

5 yrs ago I put a new airtex module and pump in my z and learned afterwards that replaceing just the pump motor is
the way to go.

With my new airtex module the gas guage only worked for about three months after.
Dropping the tank or pulling the bed is too much work too remove and play with the module.
I've been using the tripometer as a guide and usually only fill the tank till the pump clicks off the first time.
__________________
81 camaro 355 4/spd 342 posi my first love.
67 swb step 454/4spd ott 373 posi 4/7 drop.
71 c20 4x4 400/4 spd....01 sporty 883.
2000 s10 zr2 little blue truck that never gets stuck.
09 hhr. Momma's wagon. 06 chevy cobalt,blue light special
'74 heald super bronc vt8. tecumseh powered moon rover.
midniteblues is offline   Reply With Quote
Old 07-06-2017, 02:05 PM   #3
abig84
Registered User
 
Join Date: Jan 2017
Location: wheaton IL
Posts: 438
Re: 01 Blazer Gas Gauge Issue

id vote its most likely the sender. but we had a dodge charger come into work a few weeks back where she brought it to the dealer and they said the same thing that she needed the sending unit replaced. ended up being the dash cluster, using all my years of experience i used a old trick of smacking the dashboard everytime it crapped out and it started working again.
abig84 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com