The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 99-06 Chevy and GMC Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 10-14-2016, 10:26 PM   #1
pamoffa
Registered User
 
Join Date: Jun 2006
Location: massachusetts
Posts: 100
2003 head issue

I've waited a while before posting to make sure i wasn't jumping the gun, I've had the dreaded coolant leak into the oil for a few years now and my way of dealing with it was to frequently change the oil. months ago I put in the ac delco coolant seal tabs and to my surprise I didn't lose any coolant for months and let it go a while longer and still no coolant loss. So considering that I also had a bad engine tick i removed the valve covers and witnessed a terrible mass of gunk all over everything I cleaned it out and replaced the badly worn push rods and after putting it back together no ticks the oil pressure gauge is extremely responsive to the throttle and still no coolant loss. i might have saved my baby. I have the casteck 706 heads and 100% think I have the bad ones I was concerned about the tablets but I mixed them up in water before I put them in and It looked rather benign to me so i put 4 tabs in and my heat still works so It didn't screw up the heater core yet.
pamoffa is offline   Reply With Quote
Old 12-30-2016, 09:57 PM   #2
pamoffa
Registered User
 
Join Date: Jun 2006
Location: massachusetts
Posts: 100
Re: 2003 head issue

12-30-16 I still don't have any coolant loss the truck is running quiet heat still works the oil pressure gauge is still very responsive to the throttle. those ac delco coolant tablets 100% stopped my coolant loss into the oil. I was adding coolant frequently and haven't added a drop since my last post I emailed gm about the casteck heads and they played dumb.
pamoffa is offline   Reply With Quote
Old 12-30-2016, 10:38 PM   #3
pamoffa
Registered User
 
Join Date: Jun 2006
Location: massachusetts
Posts: 100
Re: 2003 head issue

I dont have the email from gm anymore wish I had it but they alluded to not knowing anything about the issue in an indirect way. very indirect so I couldn't get any sense from the email and there wasn't any direction to go further with it. so I dropped it.
pamoffa is offline   Reply With Quote
Old 05-06-2017, 12:10 AM   #4
pamoffa
Registered User
 
Join Date: Jun 2006
Location: massachusetts
Posts: 100
Re: 2003 head issue

update it is now 5-6-17 and i still haven't had a drop of coolant loss since I added the ac delco coolant tabs the tabs definitely stopped the coolant getting into the oil my last two oil changes no clumps. history on the issue is in my last posts on this thread
pamoffa is offline   Reply With Quote
Old 06-11-2017, 01:09 AM   #5
rickpilgrim
Registered User
 
Join Date: Apr 2011
Location: Wausau, WI
Posts: 549
Re: 2003 head issue

Very interesting as I also have the 706 castec heads on our 04 suburban and my coolant loss is very minor(gal every 4-6 months) and we change oil every 22-2500 mi to keep the "white paste" out of the valve covers. I'll have to try the ac/delco coolant tabs and see what happens.
rickpilgrim is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com