The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1960 - 1966 Chevrolet & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 08-06-2017, 09:35 AM   #1
Rust-O-Matic
Registered User
 
Rust-O-Matic's Avatar
 
Join Date: Apr 2015
Location: Gallatin, MO
Posts: 208
1966 "Def" lever hitting defrost duct hose. Correct routing?

Hey guys, I just installed a new set of levers in the heater controls (and all 3 cables) in my '66. It's the Deluxe heater with 3 levers in case that makes any difference. My truck also has original A/C.

Now, the problem is the heater lever on the left hits the defrost duct hose when I push the lever down, so it won't work. The middle and right side lever work beautifully. I cannot figure out how to get that defrost hose out of the way. Seems like no matter which way I push on it, I can't move it far enough for the lever to clear it. There's a "c" shaped sheet metal piece attached to the side of the control lever housing that looks like it's meant to hold the hose in place, but the hose doesn't even come close to touching that piece.

I'm running out of ideas, and am wondering if anyone else has a picture of how that hose/duct is supposed to be routed? I can take a pic of mine too if it would help my description any.

Any input would be fantastic. I messed with this thing all day yesterday and never could get the defrost lever to work because of the clearance problem.
Rust-O-Matic is offline   Reply With Quote
Old 08-07-2017, 11:51 AM   #2
Rust-O-Matic
Registered User
 
Rust-O-Matic's Avatar
 
Join Date: Apr 2015
Location: Gallatin, MO
Posts: 208
Re: 1966 "Def" lever hitting defrost duct hose. Correct routing?

No one else has EVER run into this problem? Not a single pic of the correct hose/duct routing on this site?
Rust-O-Matic is offline   Reply With Quote
Old 08-07-2017, 10:18 PM   #3
MusicMan70
Senior Member
 
MusicMan70's Avatar
 
Join Date: Feb 2011
Location: Chino, CA
Posts: 1,493
Re: 1966 "Def" lever hitting defrost duct hose. Correct routing?

Maybe in this long thread...


http://67-72chevytrucks.com/vboard/s...ghlight=heater
__________________
MusicMan70
1961 GMC Suburban
MusicMan70 is offline   Reply With Quote
Old 08-08-2017, 09:52 AM   #4
LVPhotos
Registered User
 
LVPhotos's Avatar
 
Join Date: Jan 2013
Location: Las Vegas, NV
Posts: 1,460
Re: 1966 "Def" lever hitting defrost duct hose. Correct routing?

From Assembly Manual
Attached Images
   
__________________
1962 shortbed 406cui small block, TKO 600 5-speed, bagged Porterbuilt suspension. 18" Salt Flats
http://www.cardomain.com/ride/332579...t-c-k-pick-up/
http://67-72chevytrucks.com/vboard/s...d.php?t=560081
LVPhotos is offline   Reply With Quote
Old 08-09-2017, 11:37 PM   #5
Rust-O-Matic
Registered User
 
Rust-O-Matic's Avatar
 
Join Date: Apr 2015
Location: Gallatin, MO
Posts: 208
Re: 1966 "Def" lever hitting defrost duct hose. Correct routing?

Quote:
Originally Posted by LVPhotos View Post
From Assembly Manual
LV you are the man! The bottom of the second image is exactly what I wanted to see. That confirms the C shaped piece is supposed to hold the hose up out of the way. Now I just gotta figure out why mine is nowhere near that piece. Maybe the duct has been shortened or something. Regardless, thanks!
Rust-O-Matic is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com