The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 99-06 Chevy and GMC Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 12-30-2016, 09:25 AM   #1
Mr Bear
Registered User
 
Join Date: Sep 2014
Location: All Over
Posts: 22
4.3L Vortec Manifold Gasket Replace/Spider Upgrade

So....its been leakin out the top side, slow but steady. Ordered the gaskets and the MPFI upgrade....they came in today and a frost plug let go too. So, can't delay any longer. Wish me luck, its a huge job.

its a 4.3L but the manifold gasket leakage and replacement is about the same on the 5.3 and 5.7. Mostly work with basic hand tools and a real pain. But, fortunately all the connectors for the electronics are different and its about impossible to confuse them and get them in the wrong spot.

So...to the job.

Here....the frost plug on the rear drivers side started weeping today.



And here on the passenger front of the motor, the intake manifold gasket has crumbled (they are plastic and 100% fail between about 100K and 150K miles....mine has 149K). Fortunatly, both leaks are to the outside and not into the oil pan. So, no washed out bearings. The intake gaskets fail to the inside about as often as not, usually destroying bearings before you find out ya got a leak.



First, I removed the air box system and then the throttle body. I'll be doing the throttle body mod (remove the blockage at about 10 oclock on the throttle plate that reduces low and midrange torque since GM surveys determined that folks didn't want lots of power off the line). Clean it up, cut off the offending blockage and reassemble for reinstall tomorrow.



Once the plastic plenum is removed, I note the original CSFI (Poppet Valve) central fuel injection. Been getting the occasional slow start. This will get replaced with the more reliable MPFI electronic fuel injection which is a standard GM upgrade since there were so many complaints about the unshrouded poppeds gunking up and sticking, etc. CSFI was last used on the Blazers in 2002. This one has 149K on it so, might as well replace it with the better/newer system now. Amazon to the rescue, $160 saved and arrived in 2 days.



To get the lower manifold off, remove everything on top. Pull the wiring up and out of the way, loosen the bolt holding the fuel pipes and pull the assembly up out of the way (no need to crack the short lines from the bracket...just blead it down before pulling out the pipes). Remove the coil. Remove the PCV, breather pipes, water neck, heater hoses, EGR, etc. I pulled the alternator for more room and also removed the ac compressor (just lay it out of the way, don't open the pipes), take off fan belt, water pump bypass hose, brake vacuum hose, distributor cap and wires.

Finally, remove about 3 bolts and 3 nuts from the AC/Steering Pump bracket and slide it forward 2" to uncover the one hidden intake manifold bolt on the DS front of the manifold.



Turn the engine by hand to TDC on the compression stroke. Rotor should point at the triangle on the dizzy base....marked in white. There is no timing adjustment, so the dizzy has to go back in exactly on these marks or it won't run right or at all. Once the dizy is out, do not rotate the engine or the oil pump drive shaft, so that later, you can back the rotor (counter clockwise) up to line up the marks on the lower shaft and drop it right back in the hole. When the marks line up like shown, you'll know its in right and will start and run.



Pull the eight bolts that secure the lower manifold to the heads. Yank the manifold and you get to see the crumbling and broken plastic GM gaskets. Even with the radiator/block drained, you'll get some coolant in the valley, that'll have to be mopped out and with all the work, an oil and filter change, immediately, is indicated.







Cleaned up and the new Fel Pro perminant gaskets sitting in place on the heads. Threaded holes were swarfed out with solvent and a good set of gunbrushes. You can tap them too but will need a long extension for the tap....brush is easier if they are not too cruddy. RTV is used on the front and rear in the valley. And a bit more sopping up coolant to do. Final assembly will be tomorrow. For now, cleaning all the threads on bolts so they can be sealed and properly torqued. While in there I replaced the valve cover gaskets. The plenum and fuel rails will get all new Fel Pro gaskets too, they are in the kit. $20 saved on Amazon for the Fel Pro best kit and again, here in 2 days. They all arrived as I was finishing cleaning up the manifolds!




Tomorrow is reassembly and I have to fix the frost plug. Then a 24 hour sit for the RTV to cure and with luck, Monday morning is Fire Up.
__________________
Ha! Gotcha!
Mr Bear is offline   Reply With Quote
Old 12-30-2016, 09:30 AM   #2
Mr Bear
Registered User
 
Join Date: Sep 2014
Location: All Over
Posts: 22
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

Started at 700 this morning, worked till 330 including cleaning up the tools and garage. Got it all back together and battery back in, no smoke. Did not start it yet. The label on the fel pro RTV for the front and rear of the manifold says 15 minutes to skin, 5 hours to dry, 24 hours to cure. So, can't put the coolant back in till about 0800 Monday. For now, I've triple checked it all and have no left over parts and all the connections are made, hoses and electrical. Also tightened up the two weeping frost plugs....hopefully they will seal otherwise I'll have to dismount the motor.

Removed the gaskets first thing this morning and dry fit the manifold three times to ensure I could hit the guide studs I put in and had all the cables and hoses routed out of the way so the manifold would drop down straight onto the gaskets and rtv at the ends with no smear. Wound up finding that the best position was belly across radiator, feet on garage door.....so, gaskets on and guide studs in place and rtv on the ends....



Slipped the manifold right into place without any slippage that could have knocked out the rtv on the ends. After sealing the manifold bolts with white pipe thread sealer, I put some in finger tight and pulled the guide studs and started torqueing the manifold bolts. Three torques, 50, 100 and 144 in lbs in the proper cross sequences and did a final check to ensure all were at 144 in lbs....just for peace of mind. Here, the MPFI sits on the original manifold in place of the popped valve injection. I reused the poppet valve bracket, the mpfi injectors snap right onto the original bracket. The MPFI is a standard motors product from amazon, about $160 less than the price at the parts stores.



Stabbed the dizzy, no dice, a tooth off....pulled aligned the lower dimple with the line and stabbed again 5 more times, no dice, would not seat except when off mark. Finally got a long screwdriver down in there, rotated the oil pump shaft a touch clockwise, realigned the dizzy and dropped it in and finally, seated on mark. I'm hoping I got it right. If not it'll either not start or run rough as a cob....but I have high hopes.....I believe its right. Here's a photo of it seated but off mark....one tooth off and 30 minutes to get it to pick up the right gear tooth and bottom out.



Here most of the manifold fittings and electrics and modified throttle body is back in place. I worked back to front in order to ensure I didn't cover up something that needed hooked up!



Everything back in, bolted/torqued/snugged/lubed/sealed, etc. Looks right. Many double checks as I went and upon finishing up. Fixed a broken windshield washer line....no more drip there either. Coolant in the radiator tomorrow morning and I'll turn the key. At least here, with the battery hooked back up, I'm not seeing any smoke!



Drivers side rear frost plug that was leaking. The press in plug was replaced with an expandable plug and I put my wrench on the nut,,,,,finger tight. So, snugged it up and the weep stopped. So, we'll see. With luck, and even though this one can be got to without raising the motor, I'd rather try snugging it up for now than replacement. It was only put in this summer when the motor mounts were replaced. Fingers crossed. Close inspection reveled another expansion plug on the Passenger front under the motor mount....and I found a drop of coolant on that motor mount....so......sliding my 3/16" thick open wrench into the 5/16" open slot between the motor mount and the block, I find the nut on the expansion plug.....spend several minutes figuring out upsidedown-clockwise to tighten and sure enough, it was only finger tight. Gave it a good snugging up. They leak now, its goin to a shop to have the motor lifted out!



I think the hard part now is waitin till the rtv cures.
__________________
Ha! Gotcha!

Last edited by Mr Bear; 12-30-2016 at 09:36 AM.
Mr Bear is offline   Reply With Quote
Old 12-30-2016, 09:33 AM   #3
Mr Bear
Registered User
 
Join Date: Sep 2014
Location: All Over
Posts: 22
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

All done. So far, seems all successful. After a 30 mile test run, it appears to be gas, oil, coolant and vacuum tight.

Got up and went out at 830 (24.5 hour cure on the RTV on the intake ends) and filled Pixie with coolant. Checked for any leaks at the freshly tightened frost plugs and the pesky drain that always weeps on a plastic radiator (I have long since learned to pack the drain threads with a bit of soft setting pipe sealer in addition to its rubber o-ring), and every thing looked good.

With some light trepidation, I got in, set the park brake and turned the key. Two turns and Pixie fired up and settled into cold high idle. Let her run for 45 minutes with the heat on high checking everything for leaks....couldn't find any.

So, took her for a 30 mile run on the highway and noted a high hot idle. Usually she idles along at 650 rpm.....it was up around 750 to 800 and the throttle pedal felt stiff. Otherwise no issues. Check engine light is on but I expected that after replacing so much stuff and having powered it up with the battery install before reconnecting the MAF sensors. It should clear in about 75 miles of driving or several warm/cold cycles. If not, I'll check with the OBD reader at Oreilly's.

In the meantime, the combination of MPFI and the throttle body mod made the low range torque come on much better. She no longer works hard to climb the hills out of the neighborhood in lower gears, acceleration is better, idle is smoother and the hot restarts are instant, no lag with the new injectors.

Got back to the house, checked again for leaks and none noted. So....changed the oil and wix filter. I went ahead and switched to 5W30 full synthetic since its a fairly high mileage engine.

I took off the air cleaner hat and looked at the routing of the throttle cable. Had it on the wrong side of the PCV valve assembly adding an extra bend. Put it back where its supposed to be and the throttle freed up. In addition, with the reroute of the cable RPM at hot idle dropped back to a comfortable 700 RPM, only slightly higher than the usual 650ish it used to run.

It seems I got it right.....for now!

-------------------

It looks like an unexpected side benefit of switching to Mobile 1 Synthetic oil (5W30) on this high mileage engine is an overall increase of oil pressure.

Regularly, Dinosaur Oil provided me hot readings of 18 psi Idle and 35 psi at Speed.

It would appear that Fake Oil is going to provide somewhat improved figures of 25 psi Idle and 45 psi at Speed.

-------------------------

250 miles have rolled under Pixie's 10.5" wide tires and she's still idling 900 with an engine light. We idle along in traffic with the brake on to keep it below 30 mph.

So, came home this evening, sprayed out the Idle Air Control slot in the throttle body with carb spray. Some better....so, I did the idle relearn for the 275th time. 800 rpm progress, figured I'd give it another 100 miles and see. So, went hunting in the back yard, killed a doe and on the way to get ice and a cigar its idling 1500 and 1000 and 700 and 1800 and well, we limped home and processed the deer.

Took a shower and thought it over.

Went back out, fired it up, sprayed everything between the fender wells with carb cleaner and wd40 looking for vacuum leaks. None.

Shut Pixie off and yanked the IAC stepper valve out of the throttle body (had been to oreilly this PM and the single code was P0507, unexpected high idle...yeah, I already knew that. Unfortunately its a generic Diagnostic code with about many causes. But my problem wasn't on the GM list of causes). Anyway, the IAC valve was a touch cruddy, cleaned it....cleaned the seat, lubed the o-ring and reinstalled. Started Pixie....700 rpm....great....till I blipped the throttle....Pixie stuck at 1000 rpm.

Scratched my head. Scratched my belly. Could it be?.....

Pulled the air hat, got a flashlight and looked down on the throttle blade I had removed to modify (removal of the blockage to increase low and midrange torque).....

Flipped the throttle plate gently, sticky.....wiped it out...flipped it, sticky....right there at closing sticks. It can be forced closed but not under spring power.

Looked close, back half of the throttle has a gap as wide as a hair, i.e. not wide at all.

Could it be that simple?

Loosened the torx screws on the plate, bumped the throttle twice gently so the plate aligned.....retorqued the torx screws and flipped the plate again. No hair line gap on the back half and no sticky throttle.

Got back in the drivers seat, bumped the gas pedal, no sticking! Started Pixie, fired right up, settled in at 550 RPM. Shut down and started again three more times, same result....550 RPM idle.

I think its fixed. Test ride tomorrow and that pesky engine light should reset by itself now.

I'll let ya know.
__________________
Ha! Gotcha!
Mr Bear is offline   Reply With Quote
Old 12-30-2016, 09:34 AM   #4
Mr Bear
Registered User
 
Join Date: Sep 2014
Location: All Over
Posts: 22
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

I must have got it right. Pixie has been idling properly since the Thursday evening tweak. Smooth powerful acceleration and fast response with no sticking of the throttle off idle. Idle hot and steady at 550 rpm.

Check engine light stayed on since it was still carrying the P0507 unexpected high idle code in the computer.

Been driving a bit, about 75ish miles and on the way to work this morning the light was still on.

Pulled up to the parking lot, engine at idle and that glaring yellow light goes out.

I love it when a plan comes together.
__________________
Ha! Gotcha!
Mr Bear is offline   Reply With Quote
Old 12-30-2016, 09:34 AM   #5
Mr Bear
Registered User
 
Join Date: Sep 2014
Location: All Over
Posts: 22
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

Update. Got the first good miles per gallon calculations since the repairs. Pixie is pulling 19.7mpg combined city/hwy. That's up a bit more than 1.5 full mile per gallon over where she was regularly performing prior to the repairs.

Looks to me like the benefits of mpfi and throttle body mod are very much worth doing on a higher mileage Vortec.
__________________
Ha! Gotcha!
Mr Bear is offline   Reply With Quote
Old 12-30-2016, 10:19 AM   #6
faribran
Registered User
 
Join Date: Jul 2005
Location: AL
Posts: 1,788
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

Great work. Thanks for sharing.
__________________
"
faribran is offline   Reply With Quote
Old 12-30-2016, 10:31 AM   #7
Mr Bear
Registered User
 
Join Date: Sep 2014
Location: All Over
Posts: 22
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

I was surprised. At 150000 miles, the throttle body and the butterfly are still so precise in fit that the slightest misalignment could make such a difference. About two weeks of driving since the final fixes and everything is fine. I'm quite pleased and my mileage is staying in the mid 19 mpg range. I got 21+ on one tank running mostly highway, 65 mph and under. Overall, I'm reasonably happy I did the job, even though it was about 2.5 days of steady work.
__________________
Ha! Gotcha!
Mr Bear is offline   Reply With Quote
Old 12-30-2016, 10:34 AM   #8
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,458
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

Thanks for taking pics.

I do a lot of these in my shop, I find it easier to leave the intake assembled(lower, upper, and throttle body) and remove it all with the lower intake manifold. I think its easier to take all that stuff apart on the workbench than in the engine bay, especially in the fullsize trucks.


Good luck with the core plugs. hopefully you can get them to seal without pulling the motor.
__________________
-99 K2500 LS CCSB 7.4
-96 C3500 HD 7.4 NV4500 Rollback

My 85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is offline   Reply With Quote
Old 01-03-2017, 05:55 PM   #9
GASoline71
"I ain't nobody, dork."
 
GASoline71's Avatar
 
Join Date: Sep 2007
Location: Whidbey Island, Washington
Posts: 7,913
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

I just did this (intake manifold gaskets) on my Wife's 2001 Blazer. Total PITA, but worth it in the long run. I left the entire upper plenum and TB attached as one whole unit since I did not do the FI upgrade.

Nice job on the descriptions and the pics!

Gary
__________________
'cuz chicks dig scars...

My 1972 GMC 1500 Super Custom (Creeping Death) "long term" build thread.

The Rebuild of Creeping Death after the wreck

Quote:
Originally Posted by LONGHAIR View Post
I would never rebuild a 305.
Quote:
Originally Posted by prostreetC-10 View Post
I love using vacuum gauges as part of the carb tuning process. I hook the gauge to the inside of my garbage can and leave it there.

Last edited by GASoline71; 01-03-2017 at 06:01 PM.
GASoline71 is offline   Reply With Quote
Old 01-04-2017, 12:56 AM   #10
68c10airstream
Senior Member
 
68c10airstream's Avatar
 
Join Date: Mar 2013
Location: Marquette michigan
Posts: 663
Re: 4.3L Vortec Manifold Gasket Replace/Spider Upgrade

Any of you guys fight getting these motors out for replacement. If its an auto trans my trick that saves a lot of time is this;

I pull the distributor to remove the top 2 bell housing bolts and leave them sit there.

Now this is the best part. with all of the bell housing bolts out and you are about to fight pulling the motor forward and up try this; go to the trans mount and take the 2 bolts that attach the mount to the transfer case adapter, take a prybar and pry the trans rearward until you can thread one of the bolts back into the adapter BEHIND the mount. Now hook onto the motor and pic it straight up with no fight. With the trans pulled back, when you look down from topside you will see the flexplate teeth starring at you.

And when you go to re-install the engine you just set it down on the mounts, remove the trans mount bolt and pry the trans forward and it just falls into place.

In the late 90's early 2000's i swapped many long blocks in the s-10 on a saturday for a flat $500.00. Easy money! But i hate the manual trans's job
68c10airstream is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com