The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-05-2014, 07:28 PM   #1
Bjaxs
Registered User
 
Join Date: May 2014
Location: Redlands ca
Posts: 4
68 C10 headlights stopped working ?

Hi all,
I'm new here and hoping someone can help.
One day my high beams wouldn't come on but the lights still worked and the very next day both of them went out.
I have replaced the switch in the dash twice just to be sure and then replaced the dimmer switch on the floor and still no headlights. Everything else works fine so I took the dash apart and inspected all the wires and everything is connected good with no burned looking wires or frays anywhere so I am really at a loss as to what to do next, does anyone have a suggestion or point me in another direction?
The 327 engine and trany was done with new wiring less than 10k miles ago so it's not an old system and I am not a mechanic and was hoping to learn stuff on the way but I'm just lost now..
Thanks in advance for anyone taking their time to post.
Bjaxs is offline   Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com