The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1988 - 1998 Chevy & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 07-02-2017, 02:44 AM   #1
cam.man67
Registered User
 
cam.man67's Avatar
 
Join Date: Jun 2010
Location: Jefferson, MD
Posts: 2,358
ANOTHER "my '96 GMC idles high" thread...

Man, I'm getting fed up with this truck. After chasing high idles issues for two years now...the high idle is back (it does periodically go away)!!! Or I guess I should say, never really left! @&$#!

Here's the symptoms:

After warm-up, the truck will idle at 900 in P, 750 in D. Not terrible, but this only happens after the truck gets shut off (after warm-up) for a period of time. In other words, if just left running, the choke never comes off and the truck will idle at 1500 all day long.

In addition, after shutting the truck off and restarting it, the truck immediately zooms to a 1500rpm idle, and will stay there for about 10 seconds before coming down to 900. If I put it in D before the idle comes down, it will not come down at all for the length of my trip.

This is all without a/c. With the a/c on, however (no matter if the compressor is cycles on or not), the truck idles erratically between 1000 and 1200. If I then go to put it in D, I can feel the truck accelerate against the brake. The truck will, if I let off the brakes, accelerate to 25mph without me ever touching the gas.

Trippy, right?

Here's what I've done in the past two years, all to basically no effect):
-new timing chain
-new plugs (2x)
-new cap, rotor (2x)
-new plug wires
-new thermostat
-new radiator
-new TPS (2x)
-new IAC
-shop-checked for vacuum leaks (2x)

All this has done nothing but lighten my wallet. The truck has no codes, no warning lights, and runs fine other than the stupid idle. No loss of power or anything.


I'm honestly wondering whether I'm going to have to replace the ECU at this point. I can't figure out what else could possibly cause this weirdness. Is there anything else you'd recommend I do before that point?
__________________
'68 Dodge Dart 270, 225, 904, 2.76--"Lucy"
1996 Gmc 1500 Z71, 350, 4l60e, 3.73s
1995 Jeep Wrangler Rio Grande 2.5, AX5, 4.10s
1989 Toyota Pickup 22re, auto, 3.73

Last edited by cam.man67; 07-02-2017 at 02:54 AM.
cam.man67 is offline   Reply With Quote
Old 07-02-2017, 08:08 AM   #2
speedygonzales
Registered User
 
speedygonzales's Avatar
 
Join Date: Jan 2006
Location: Smithfield, VA
Posts: 1,256
What about the throttle body????????????

Have you actually looked into the throat of the throttle body to see what the throttle plate is doing?

If you still have the stock arrangement, there is a sheet metal deflector riveted to the bottom of the throttle plate. Ive' seen the rivets loose so many times, there was actually a vehicle that the deflector came off and lodged into the opening so the engine took off.

I removed mine several years ago and plugged the holes.

Let us know, I have another suggestion if that's not it.
__________________
99 Z71 (98 body style)
Pride and joy
speedygonzales is offline   Reply With Quote
Old 07-03-2017, 08:09 AM   #3
sntrym95
Registered User
 
sntrym95's Avatar
 
Join Date: Jan 2006
Location: Cleveland, Oh
Posts: 539
Re: ANOTHER "my '96 GMC idles high" thread...

I didn't see in your list that you tested the coolant temp sensor. It's the one in intake manifold, not the head. Check the specs here to make sure that it is sending the correct reading to the ECU. http://67-72chevytrucks.com/vboard/s...d.php?t=425788
__________________
Mike

Toy list:
1995 C1500 Ext. Cab 5.7
1995 GMC Yukon 4dr 2wd 5.7 Vortec conversion, AAM TracRite
1994 Genesis 2001 Bowrider 4.3L Merc Alpha One Gen 2
sntrym95 is offline   Reply With Quote
Old 07-03-2017, 11:47 AM   #4
Kudzupatch
Registered User
 
Kudzupatch's Avatar
 
Join Date: Apr 2013
Location: GUNTERSVILLE
Posts: 410
Re: ANOTHER "my '96 GMC idles high" thread...

It was a throttle body car but I had a buildup in it that simply wouldn't let the butterfly close fully.
Kudzupatch is offline   Reply With Quote
Old 07-05-2017, 07:00 AM   #5
cam.man67
Registered User
 
cam.man67's Avatar
 
Join Date: Jun 2010
Location: Jefferson, MD
Posts: 2,358
Re: ANOTHER "my '96 GMC idles high" thread...

Quote:
Originally Posted by speedygonzales View Post
Have you actually looked into the throat of the throttle body to see what the throttle plate is doing?

If you still have the stock arrangement, there is a sheet metal deflector riveted to the bottom of the throttle plate. Ive' seen the rivets loose so many times, there was actually a vehicle that the deflector came off and lodged into the opening so the engine took off.

I removed mine several years ago and plugged the holes.

Let us know, I have another suggestion if that's not it.

Thanks for the suggestion! No, I just checked and everything is good and tight in there. No loose rivets. The throttle is also not sticking.

Quote:
Originally Posted by sntrym95 View Post
I didn't see in your list that you tested the coolant temp sensor. It's the one in intake manifold, not the head. Check the specs here to make sure that it is sending the correct reading to the ECU. http://67-72chevytrucks.com/vboard/s...d.php?t=425788
Thanks for that! According to my multimeter, as 72 degrees, it's testing at 2890 ohms. Post warm-up, at 190 degrees, it reads 214 ohms.
__________________
'68 Dodge Dart 270, 225, 904, 2.76--"Lucy"
1996 Gmc 1500 Z71, 350, 4l60e, 3.73s
1995 Jeep Wrangler Rio Grande 2.5, AX5, 4.10s
1989 Toyota Pickup 22re, auto, 3.73

Last edited by cam.man67; 07-05-2017 at 09:21 AM.
cam.man67 is offline   Reply With Quote
Old 07-05-2017, 09:56 PM   #6
sntrym95
Registered User
 
sntrym95's Avatar
 
Join Date: Jan 2006
Location: Cleveland, Oh
Posts: 539
Re: ANOTHER "my '96 GMC idles high" thread...

Check the mass air flow sensor, MAP sensor, and anything else electrical. It might help to get a computer hooked up the diagnostic port to see if any sensor is reporting the wrong info to the PCM. If everything looks good, then it could be the PCM.
__________________
Mike

Toy list:
1995 C1500 Ext. Cab 5.7
1995 GMC Yukon 4dr 2wd 5.7 Vortec conversion, AAM TracRite
1994 Genesis 2001 Bowrider 4.3L Merc Alpha One Gen 2
sntrym95 is offline   Reply With Quote
Old 07-05-2017, 10:31 PM   #7
mountie
Senior Member
 
mountie's Avatar
 
Join Date: Jun 2011
Location: Bradenton, Fla.
Posts: 853
Re: ANOTHER "my '96 GMC idles high" thread...

He mentioned the TPS was replaced ( 2 times?)..

Uh, is it adjusted correctly? ( UN-adjusted, will drive you nuts...)
__________________
'70 GTO Midnight Blue
'73 Chevelle Malibu Silver
'88 GMC Sierra SLE Camper Pkg 375,000 & still going!
'93 Cadillac STS Black
'93 Mercedes SL 500 Teal
'96 Honda 550
'86 Yamaha FZ750
'86 Yamaha FJ1200
mountie is offline   Reply With Quote
Old 07-06-2017, 06:36 AM   #8
speedygonzales
Registered User
 
speedygonzales's Avatar
 
Join Date: Jan 2006
Location: Smithfield, VA
Posts: 1,256
Iac

Did you check and or clean the IAC port?

Have you attempted to see what happens with the IAC disconnected?
__________________
99 Z71 (98 body style)
Pride and joy
speedygonzales is offline   Reply With Quote
Old 08-03-2017, 01:37 PM   #9
87Skier
Registered User
 
87Skier's Avatar
 
Join Date: Mar 2014
Location: Corvallis, OR
Posts: 540
Re: ANOTHER "my '96 GMC idles high" thread...

You should verify the engine temp through the computer by using a OBD II scanner. I have one of these and Amazon and they give you a lot more diagnostic information than a cheapo scanner.
__________________
1972 GMC Jimmy Custom 350 SBC TH350
1996 Chevy Burb K1500 5.7 Vortec
87Skier is offline   Reply With Quote
Old 08-03-2017, 05:10 PM   #10
cam.man67
Registered User
 
cam.man67's Avatar
 
Join Date: Jun 2010
Location: Jefferson, MD
Posts: 2,358
Re: ANOTHER "my '96 GMC idles high" thread...

So I found the problem guys. Turns out it was a faulty IAC. I guess that's what I get for buying cheaper replacement parts the last time around.
__________________
'68 Dodge Dart 270, 225, 904, 2.76--"Lucy"
1996 Gmc 1500 Z71, 350, 4l60e, 3.73s
1995 Jeep Wrangler Rio Grande 2.5, AX5, 4.10s
1989 Toyota Pickup 22re, auto, 3.73
cam.man67 is offline   Reply With Quote
Old 08-03-2017, 05:33 PM   #11
Kudzupatch
Registered User
 
Kudzupatch's Avatar
 
Join Date: Apr 2013
Location: GUNTERSVILLE
Posts: 410
Re: ANOTHER "my '96 GMC idles high" thread...

Quote:
Originally Posted by cam.man67 View Post
I guess that's what I get for buying cheaper replacement parts the last time around.
Now days it almost always pays to buy GM parts. I learned that lesson the hard too.

Last edited by Kudzupatch; 08-04-2017 at 08:31 AM.
Kudzupatch is offline   Reply With Quote
Old 08-03-2017, 07:00 PM   #12
mountie
Senior Member
 
mountie's Avatar
 
Join Date: Jun 2011
Location: Bradenton, Fla.
Posts: 853
Re: ANOTHER "my '96 GMC idles high" thread...

Yea... genuine GM parts website..... Lot's of discontinued parts.

Besides way over priced, if they have the part.

( but fortunately many aftermarket sites still have GM stuff)
__________________
'70 GTO Midnight Blue
'73 Chevelle Malibu Silver
'88 GMC Sierra SLE Camper Pkg 375,000 & still going!
'93 Cadillac STS Black
'93 Mercedes SL 500 Teal
'96 Honda 550
'86 Yamaha FZ750
'86 Yamaha FJ1200
mountie is offline   Reply With Quote
Old 12-03-2017, 05:23 PM   #13
cam.man67
Registered User
 
cam.man67's Avatar
 
Join Date: Jun 2010
Location: Jefferson, MD
Posts: 2,358
Re: ANOTHER "my '96 GMC idles high" thread...

...and we're back. Still idling high, now about 1000-1100 in P and 800-850 in D. In addition to the above repairs, I have since replaced the starter (unrelated), temp sensor, cleaned the MAF, and wire-brushed all the grounds I can find under the hood. Getting abysmal fuel economy (about 9 mpg), but it's not smelling rich, and aside from the high ide the truck runs well. At my wits end about this stupid thing.
__________________
'68 Dodge Dart 270, 225, 904, 2.76--"Lucy"
1996 Gmc 1500 Z71, 350, 4l60e, 3.73s
1995 Jeep Wrangler Rio Grande 2.5, AX5, 4.10s
1989 Toyota Pickup 22re, auto, 3.73
cam.man67 is offline   Reply With Quote
Old 12-03-2017, 08:25 PM   #14
mountie
Senior Member
 
mountie's Avatar
 
Join Date: Jun 2011
Location: Bradenton, Fla.
Posts: 853
Re: ANOTHER "my '96 GMC idles high" thread...

Quote:
Originally Posted by cam.man67 View Post
...and we're back. Still idling high, now about 1000-1100 in P and 800-850 in D. In addition to the above repairs, I have since replaced the starter (unrelated), temp sensor, cleaned the MAF, and wire-brushed all the grounds I can find under the hood. Getting abysmal fuel economy (about 9 mpg), but it's not smelling rich, and aside from the high ide the truck runs well. At my wits end about this stupid thing.
Remind me... was there a Check engine soon code?
__________________
'70 GTO Midnight Blue
'73 Chevelle Malibu Silver
'88 GMC Sierra SLE Camper Pkg 375,000 & still going!
'93 Cadillac STS Black
'93 Mercedes SL 500 Teal
'96 Honda 550
'86 Yamaha FZ750
'86 Yamaha FJ1200
mountie is offline   Reply With Quote
Old 12-04-2017, 08:34 AM   #15
cam.man67
Registered User
 
cam.man67's Avatar
 
Join Date: Jun 2010
Location: Jefferson, MD
Posts: 2,358
Re: ANOTHER "my '96 GMC idles high" thread...

Quote:
Originally Posted by mountie View Post
Remind me... was there a Check engine soon code?
Nope, no codes, no lights. Nothing.
__________________
'68 Dodge Dart 270, 225, 904, 2.76--"Lucy"
1996 Gmc 1500 Z71, 350, 4l60e, 3.73s
1995 Jeep Wrangler Rio Grande 2.5, AX5, 4.10s
1989 Toyota Pickup 22re, auto, 3.73
cam.man67 is offline   Reply With Quote
Old 12-04-2017, 10:11 AM   #16
mountie
Senior Member
 
mountie's Avatar
 
Join Date: Jun 2011
Location: Bradenton, Fla.
Posts: 853
Re: ANOTHER "my '96 GMC idles high" thread...

Quote:
Originally Posted by cam.man67 View Post
Nope, no codes, no lights. Nothing.
I replaced my ECM 3 times in a year...... and I think it is failing again.

( That may be a clue ??) I wish I can find a good ECM for once.
__________________
'70 GTO Midnight Blue
'73 Chevelle Malibu Silver
'88 GMC Sierra SLE Camper Pkg 375,000 & still going!
'93 Cadillac STS Black
'93 Mercedes SL 500 Teal
'96 Honda 550
'86 Yamaha FZ750
'86 Yamaha FJ1200
mountie is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com