The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1967 - 1972 Chevrolet & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 04-27-2019, 12:06 PM   #1
PGG
Senior Member
 
Join Date: Mar 2015
Location: Fort Worth Texas
Posts: 276
Thermostats going bad 2 in 7 months?

I have had two AC delco brand new thermostats go bad in 7 months is there a problem in warm weather just leaving the damn thing out?
Is there a thermostat that is made worth a **** anymore?
I also had a brand new mechanical fuel pump go bad a 500 miles
I guess everything is made in china now or something.

Thanks for any suggestions. PG
PGG is offline   Reply With Quote
Old 04-27-2019, 12:23 PM   #2
SavageC20
Registered User
 
SavageC20's Avatar
 
Join Date: Sep 2018
Location: California
Posts: 97
Re: Thermostats going bad 2 in 7 months?

I have had good luck with Stant Superstats. They're like $7 on Amazon and still made in USA. I bought a Carter fuel pump for my 454 and it hasn't failed yet I think it was $14.
SavageC20 is offline   Reply With Quote
Old 04-28-2019, 09:27 AM   #3
special-K
Special Order
 
special-K's Avatar
 
Join Date: Nov 2004
Location: Mt.Airy,MD
Posts: 68,700
Re: Thermostats going bad 2 in 7 months?

I use Stant as well. It's what they do. But could it be something about your coolant causing it to stick?

I always use AC or one from a carburetor company like Holley or Carter
__________________
"BUILDING A BETTER WAY TO SERVE THE USA"......67/72......"The New Breed" GMC

'67 C1500 Wideside Super Custom SWB: 327/M22/3.42 posi..........'The 67' (project)
'72 K2500 Wideside Sierra Custom Camper: 350/TH350/4.10 Power-Lok...'The 72' (rolling)
Tim

"Don't call me a redneck. I'm a rough cut country gentleman"

R.I.P. ~ East Side Low Life ~ El Jay ~ 72BLUZ ~ Fasteddie69 ~ Ron586
special-K is offline   Reply With Quote
Old 04-28-2019, 01:12 PM   #4
CastIron
Registered User
 
CastIron's Avatar
 
Join Date: May 2013
Location: Oregon
Posts: 269
Re: Thermostats going bad 2 in 7 months?

You didn't say if they failed by not opening or opening too soon. I'm guessing they stuck closed? I'd say it unusual to have that happen, but maybe they had a bad batch.
I use Stant thermostats and haven't had any problems. And a Carter mechanical fuel pump that I installed a few years ago with no problems.
CastIron is offline   Reply With Quote
Old 04-28-2019, 03:47 PM   #5
KQQL IT
At the body shop.
 
KQQL IT's Avatar
 
Join Date: Aug 2009
Location: California for now...
Posts: 3,971
Re: Thermostats going bad 2 in 7 months?

I put a aluminum high volume water pump on my sb400 and it would hold the the t-stat closed. Put the standard pump back and the problems stopped.
__________________
" That didnt make it any newer "
" Dont antique the equipment "
KQQL IT is online now   Reply With Quote
Old 04-28-2019, 03:59 PM   #6
Chris_oz
Registered User
 
Chris_oz's Avatar
 
Join Date: Sep 2018
Location: Newcastle, New South Wales, Australia
Posts: 105
Re: Thermostats going bad 2 in 7 months?

Stant here also, never an issue.

Be sure they are installed the correct way, I have seen several put in "up side down" which delays the opening and makes them close too fast.

I also loke to add a 5/32" hole to help bleed when filling the radiator, gets the air out of the block so much faster with compomising how the thermostat works.
Chris_oz is offline   Reply With Quote
Old 05-13-2019, 12:52 AM   #7
lok-dawg
Registered User
 
lok-dawg's Avatar
 
Join Date: Mar 2004
Location: Meridian, ID
Posts: 37
Re: Thermostats going bad 2 in 7 months?

Had some issues with new thermostats too. I believe Murray is the brand. One was bad right out of the box and just simply would not open and engine would overheat immediately. Next one would take too long to open at times, it's become less finicky over time. I think I'd like to replace it though. Probably with a Stant based on the replies here.
__________________
'72 Chevrolet C10- Deluxe/5.7/Short Fleetside
'02 Chevrolet Tahoe- LT/5.3/4x4
'14 Subaru Impreza- Limited/2.0/Sedan/AWD
lok-dawg is offline   Reply With Quote
Old 05-13-2019, 09:12 AM   #8
toolboxchev
Registered User
 
Join Date: Jul 2015
Location: 2nd left past the stump on a dirt road.
Posts: 1,696
Re: Thermostats going bad 2 in 7 months?

Stant recommends replacement of thermostat with Coolant Flush. I would do the radiator cap also.

Here is some info for my truck from their site. I am using the SuperStant Series. I am also using a 16lb Rad Cap to help with cooling.


https://partcat.com/stant
toolboxchev is offline   Reply With Quote
Old 05-13-2019, 12:48 PM   #9
tdangle
Senior Member
 
tdangle's Avatar
 
Join Date: Mar 2005
Location: Jurupa Valley, Ca
Posts: 502
Re: Thermostats going bad 2 in 7 months?

I am also having issues with thermostats. You can actually see the temp gauge swing hot and then cool off within less than a minute. Last one I bought was a hi-po one (cant remember the manufacturer -- maybe mr gasket?) and it worked well for a month or 2 then started acting flaky too.
__________________
Terry

1970 C20 Custom Camper, 350/2004R, Dana 60, factory AC, side tool box
tdangle is offline   Reply With Quote
Old 05-13-2019, 01:18 PM   #10
rpmerf
Registered User
 
rpmerf's Avatar
 
Join Date: Feb 2011
Location: Parkville, MD
Posts: 612
Re: Thermostats going bad 2 in 7 months?

I would be looking at the rest of the system to be 100% sure it's the thermostat. Make sure the system is fully bled and 100% sealed. I've seen a pinhole leak cause a some weird issues before.

I also drill a bleed hole in the thermostat. Usually like 1/8". Some thermostats have a hole and check valve.

The high flow water pump is interesting. Makes sense.

You can test a thermostat in a pot of water with a meat thermometer. Heat up the water on the stove and see at what temperature the thermostat opens.

Verify temperatures with an infrared thermometer (temperature gun). My temperature gauge gets thrown off by my headers right next to the sender (or maybe my 195* thermostat). If I measure from the front of the head, intake manifold, block, upper hose, radiator, lower hose, it all looks good.
__________________
1970 C20 Custom Camper 350 / TH350
rpmerf is offline   Reply With Quote
Old 05-14-2019, 01:53 PM   #11
tdangle
Senior Member
 
tdangle's Avatar
 
Join Date: Mar 2005
Location: Jurupa Valley, Ca
Posts: 502
Re: Thermostats going bad 2 in 7 months?

Quote:
Originally Posted by rpmerf View Post
I would be looking at the rest of the system to be 100% sure it's the thermostat. Make sure the system is fully bled and 100% sealed. I've seen a pinhole leak cause a some weird issues before.

I also drill a bleed hole in the thermostat. Usually like 1/8". Some thermostats have a hole and check valve.

The high flow water pump is interesting. Makes sense.

You can test a thermostat in a pot of water with a meat thermometer. Heat up the water on the stove and see at what temperature the thermostat opens.

Verify temperatures with an infrared thermometer (temperature gun). My temperature gauge gets thrown off by my headers right next to the sender (or maybe my 195* thermostat). If I measure from the front of the head, intake manifold, block, upper hose, radiator, lower hose, it all looks good.
Not sure about the original poster, but I know I've run into issues I can't explain. My cooling system is in good shape, new water pump, very low mileage radiator all new hoses and no leaks. I have a closed system with an overflow reservoir new gauge sending unit and thermostat. 7 blade fan with HD clutch. 180 degree thermostat. I can be driving at a steady speed (or even stopped at a light) and watch the gauge move upward towards the upper range of the "normal" area and then just as fast go down to the bottom portion of the normal area. I have checked the true temp with a temp gun and it all seems to be in range. Almost as if the thermostat is hanging up opening and then fully opens, engine cools down right away and then maybe later does the same thing, but not always.
__________________
Terry

1970 C20 Custom Camper, 350/2004R, Dana 60, factory AC, side tool box
tdangle is offline   Reply With Quote
Old 05-14-2019, 02:49 PM   #12
MySons68C20
Registered User
 
Join Date: Sep 2014
Location: Wenatchee, Wa
Posts: 183
Re: Thermostats going bad 2 in 7 months?

Same as tdangle above.....brand new everything and the stock gauge goes to the edge of the hot range then back to the middle. It runs great no boilovers etc. I'm thinking the factory gauge may be very sensitive to a 5 or 10 degree temp swing.
I do have a new aluminum radiator with the big tubes....one thing I notice when I shut the engine off the radiator continues to make a gurgling noise.
I believe it is probably normal but not really sure.
MySons68C20 is offline   Reply With Quote
Old 05-15-2019, 06:41 AM   #13
rpmerf
Registered User
 
rpmerf's Avatar
 
Join Date: Feb 2011
Location: Parkville, MD
Posts: 612
Re: Thermostats going bad 2 in 7 months?

I had a Dodge Spirit that would fluctuate the temperature gauge. I had a pinhole leak in one of the hoses. Not sure how, but fixing that pinhole leak stopped the fluctuation.

My Integra does the gurgle after shutdown. I know that car has a leak. I have to top it off and I can see dried coolant spray. Pressure drops pretty quickly after shutdown. I should probably fix it, but that car is beater status with 360K miles, so I just top off the coolant every month.

Makes me wonder if my 1/8" bleed hole is hiding a swing that I would have without it.

Really, as long as it isn't loosing coolant, can build and maintain pressure, isn't overheating or boiling over, I'd call it good enough.
__________________
1970 C20 Custom Camper 350 / TH350
rpmerf is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com