The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 09-22-2018, 04:25 PM   #1
65truckowner
Senior Member
 
65truckowner's Avatar
 
Join Date: Oct 2012
Location: mountain view arkansas
Posts: 881
all fuses hot with battery hooked up 65 c10

I am almost done with my 65 restoration so today I put a battery on it to check out the wiring and all the fuses are hot like the switch is on. So I unplugged the switch and the same thing. All the wires coming to the switch are hot except the one going to the start side of the starter. What do I need to check. This is a 1965 c10
65truckowner is offline   Reply With Quote
Old 09-22-2018, 08:16 PM   #2
franken
Registered User
 
Join Date: Jun 2013
Location: Somewhere
Posts: 2,214
Re: all fuses hot with battery hooked up 65 c10

And what have you done with the wiring during the restoration?
franken is offline   Reply With Quote
Old 09-22-2018, 08:37 PM   #3
65truckowner
Senior Member
 
65truckowner's Avatar
 
Join Date: Oct 2012
Location: mountain view arkansas
Posts: 881
Re: all fuses hot with battery hooked up 65 c10

Nothing it was set aside then retaped and reused. I thought maybe the switch was bad but I unplugged it with the same result. I unplugged the harness at the firewall and 2 of the 5 wires where hot
65truckowner is offline   Reply With Quote
Old 09-23-2018, 09:49 AM   #4
65truckowner
Senior Member
 
65truckowner's Avatar
 
Join Date: Oct 2012
Location: mountain view arkansas
Posts: 881
Re: all fuses hot with battery hooked up 65 c10

any one have a picture of the horn relay, voltage regulator wiring on there 64-66
65truckowner is offline   Reply With Quote
Old 09-23-2018, 06:16 PM   #5
65truckowner
Senior Member
 
65truckowner's Avatar
 
Join Date: Oct 2012
Location: mountain view arkansas
Posts: 881
Re: all fuses hot with battery hooked up 65 c10

found a wire someone had added for some reason and cut it now all works like it should
65truckowner is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:45 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com