The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1988 - 1998 Chevy & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 04-28-2018, 03:00 PM   #1
SoCalSlaughter
Registered User
 
SoCalSlaughter's Avatar
 
Join Date: Aug 2010
Location: Ventura
Posts: 129
96 Silverado - Miss at hwy speed

Hello all, I'm finally tired of my truck missing like this, its getting very annoying. Truck is a 1996 C1500 5.7 auto. The truck starts and runs fine. It can cruse around town all day with no problem. But once I get onto the freeway 50mph+ there is a noticeable, intermittent miss at speed. It will cruse smooth for a minute or so then just have a miss and the truck will shudder alittle bit. If I floor it to pass someone the truck is fine, it will fly down the freeway. It seems to happen more at a steady speed. There is no engine lights on, had a full tune up about 8 months ago, fuel pressure is 56/57 psi, MAS is about a year old, crank angle sensor is free and clear of any debris, ignition timing is dead on. The only thing I haven't checked is the fuel injection spider, it still has the old poppet style in there (I know this from doing the intake manifold gaskets about 2 years ago) Thanks in advance
SoCalSlaughter is offline   Reply With Quote
Old 04-28-2018, 03:16 PM   #2
SoCalSlaughter
Registered User
 
SoCalSlaughter's Avatar
 
Join Date: Aug 2010
Location: Ventura
Posts: 129
Re: 96 Silverado - Miss at hwy speed

I'd like to add, the truck has 175k miles, the truck is mostly stock besides a factory style K&N air filter. And the last recorded DTC was P0420, O2 sensor was replaced and code hasn't come back (This was mid 2017)
__________________
1990 Chevy Suburban v2500
1990 Chevy/Geo Tracker LSi 4x4
1991 Nissan 300zx SlickTop
1996 Chevy Silverado c1500
2011 Chevy Silverado LT
SoCalSlaughter is offline   Reply With Quote
Old 04-28-2018, 04:40 PM   #3
speedygonzales
Registered User
 
speedygonzales's Avatar
 
Join Date: Jan 2006
Location: Smithfield, VA
Posts: 1,285
A miss will get recorded......so?

If it truly has a miss, it will record a 300's code. So ?
__________________
99 Z71 (98 body style)
Pride and joy
speedygonzales is offline   Reply With Quote
Old 04-28-2018, 05:45 PM   #4
SoCalSlaughter
Registered User
 
SoCalSlaughter's Avatar
 
Join Date: Aug 2010
Location: Ventura
Posts: 129
Re: 96 Silverado - Miss at hwy speed

A miss or stumble. Engine running at speed, there will be a miss, stumble, hick up, whatever you want to call it.
__________________
1990 Chevy Suburban v2500
1990 Chevy/Geo Tracker LSi 4x4
1991 Nissan 300zx SlickTop
1996 Chevy Silverado c1500
2011 Chevy Silverado LT
SoCalSlaughter is offline   Reply With Quote
Old 04-30-2018, 10:21 AM   #5
speedygonzales
Registered User
 
speedygonzales's Avatar
 
Join Date: Jan 2006
Location: Smithfield, VA
Posts: 1,285
If it is an ignition miss, it will be recorded in history codes

My point in asking about 300's was, does it have any history codes?
__________________
99 Z71 (98 body style)
Pride and joy
speedygonzales is offline   Reply With Quote
Old 05-06-2018, 11:19 AM   #6
determined
Registered User
 
Join Date: Feb 2018
Location: Saskatchewan
Posts: 14
Re: 96 Silverado - Miss at hwy speed

Good chance the gear on your distributor is almost gone.
determined is offline   Reply With Quote
Old 05-16-2018, 11:33 PM   #7
likaroc13
Rollin' Old Skool
 
Join Date: Jun 2007
Location: Spring Hill, TN
Posts: 5,020
Re: 96 Silverado - Miss at hwy speed

I've noticed my '97 Tahoe doing something similar. Around town speeds it's never noticeable. It's only when I get up to steady highway speeds. It's also random with mine. Some days it does it, & others it does just fine. I've also been on longer road trips where it would start doing it & eventually go away. Sometimes it would come back later on, but other times it never did it again. I have no clue why it does it. I haven't tried to dig into it much. I tried the fuel filter with no change. In late 2016 the distributor was replaced, & shortly thereafter the fuel pump & sending unit were also replaced. The miss wasn't there before that work was done.
__________________
_____________________________________________
Phillip

My Build threads:
1966 Chevy C-10 "Black Betty"

shortbed, fleetside, BBW, 327 V8/ Powerglide (under construction)
http://67-72chevytrucks.com/vboard/s...ighlight=betty

1997 Chevy Tahoe, 2dr/2wd, mild custom (Daily driver)
http://67-72chevytrucks.com/vboard/s...d.php?t=601142

Pics:
'66 C-10 https://flic.kr/s/aHsjHWD4h9
'97 Tahoe https://flic.kr/s/aHsjGZ7wKP
'93 C-1500 https://flic.kr/s/aHskxdpdnQ
'88 S-10 Blazer https://flic.kr/s/aHsjYGx4Md

Previous Rides:
1993 Chevy S-10 ext. cab, 4.3L, 4/5 drop (Sold)
1993 Chevy C-1500 short/step Retro-Rod (Sold)
1988 S-10 Blazer 2dr/2wd mild custom (Sold)
likaroc13 is offline   Reply With Quote
Old 05-17-2018, 12:03 AM   #8
SoCalSlaughter
Registered User
 
SoCalSlaughter's Avatar
 
Join Date: Aug 2010
Location: Ventura
Posts: 129
Re: 96 Silverado - Miss at hwy speed

I tried to start the truck the other day, it was sitting for about a week. It would turn over but wouldnt fire. It would stumble and miss. It would try and back fire out the exhaust, sometimes intake. Smells and raw fuel. The truck has spark. Im thinking something is wrong with the spider. Have to be turning it over and feathering the throttle for it to finally fire up
__________________
1990 Chevy Suburban v2500
1990 Chevy/Geo Tracker LSi 4x4
1991 Nissan 300zx SlickTop
1996 Chevy Silverado c1500
2011 Chevy Silverado LT
SoCalSlaughter is offline   Reply With Quote
Old 05-17-2018, 12:03 AM   #9
SoCalSlaughter
Registered User
 
SoCalSlaughter's Avatar
 
Join Date: Aug 2010
Location: Ventura
Posts: 129
Re: 96 Silverado - Miss at hwy speed

Quote:
Originally Posted by determined View Post
Good chance the gear on your distributor is almost gone.
The gear is fine. Had the dizzy out about a month ago. Problem was there before and after.
__________________
1990 Chevy Suburban v2500
1990 Chevy/Geo Tracker LSi 4x4
1991 Nissan 300zx SlickTop
1996 Chevy Silverado c1500
2011 Chevy Silverado LT
SoCalSlaughter is offline   Reply With Quote
Old 05-17-2018, 12:05 AM   #10
likaroc13
Rollin' Old Skool
 
Join Date: Jun 2007
Location: Spring Hill, TN
Posts: 5,020
Re: 96 Silverado - Miss at hwy speed

Quote:
Originally Posted by SoCalSlaughter View Post
I tried to start the truck the other day, it was sitting for about a week. It would turn over but wouldnt fire. It would stumble and miss. It would try and back fire out the exhaust, sometimes intake. Smells and raw fuel. The truck has spark. Im thinking something is wrong with the spider. Have to be turning it over and feathering the throttle for it to finally fire up
Wow, yeah nothing extreme like that with mine. Hope you get it figured out. Be sure to update us if you do.
__________________
_____________________________________________
Phillip

My Build threads:
1966 Chevy C-10 "Black Betty"

shortbed, fleetside, BBW, 327 V8/ Powerglide (under construction)
http://67-72chevytrucks.com/vboard/s...ighlight=betty

1997 Chevy Tahoe, 2dr/2wd, mild custom (Daily driver)
http://67-72chevytrucks.com/vboard/s...d.php?t=601142

Pics:
'66 C-10 https://flic.kr/s/aHsjHWD4h9
'97 Tahoe https://flic.kr/s/aHsjGZ7wKP
'93 C-1500 https://flic.kr/s/aHskxdpdnQ
'88 S-10 Blazer https://flic.kr/s/aHsjYGx4Md

Previous Rides:
1993 Chevy S-10 ext. cab, 4.3L, 4/5 drop (Sold)
1993 Chevy C-1500 short/step Retro-Rod (Sold)
1988 S-10 Blazer 2dr/2wd mild custom (Sold)
likaroc13 is offline   Reply With Quote
Old 05-17-2018, 12:06 AM   #11
SoCalSlaughter
Registered User
 
SoCalSlaughter's Avatar
 
Join Date: Aug 2010
Location: Ventura
Posts: 129
Re: 96 Silverado - Miss at hwy speed

Quote:
Originally Posted by likaroc13 View Post
I've noticed my '97 Tahoe doing something similar. Around town speeds it's never noticeable. It's only when I get up to steady highway speeds. It's also random with mine. Some days it does it, & others it does just fine. I've also been on longer road trips where it would start doing it & eventually go away. Sometimes it would come back later on, but other times it never did it again. I have no clue why it does it. I haven't tried to dig into it much. I tried the fuel filter with no change. In late 2016 the distributor was replaced, & shortly thereafter the fuel pump & sending unit were also replaced. The miss wasn't there before that work was done.
I'm thinking this is a fuel problem. Because my exhaust stinks of gas. I'm thinking its the fuel injection spider. Mine is the old style still. And if its leaking, just 1 drop of fuel could cause the engine to stumble
__________________
1990 Chevy Suburban v2500
1990 Chevy/Geo Tracker LSi 4x4
1991 Nissan 300zx SlickTop
1996 Chevy Silverado c1500
2011 Chevy Silverado LT
SoCalSlaughter is offline   Reply With Quote
Old 05-17-2018, 12:07 AM   #12
SoCalSlaughter
Registered User
 
SoCalSlaughter's Avatar
 
Join Date: Aug 2010
Location: Ventura
Posts: 129
Re: 96 Silverado - Miss at hwy speed

Quote:
Originally Posted by likaroc13 View Post
Wow, yeah nothing extreme like that with mine. Hope you get it figured out. Be sure to update us if you do.
Well the Silverado is on the back burner now. Found alittle bit of water in my oil in my 90' Suburban, so have the top engine disassembled at the moment.
__________________
1990 Chevy Suburban v2500
1990 Chevy/Geo Tracker LSi 4x4
1991 Nissan 300zx SlickTop
1996 Chevy Silverado c1500
2011 Chevy Silverado LT
SoCalSlaughter is offline   Reply With Quote
Old 05-18-2018, 07:23 PM   #13
Tom
driving is in my blood
 
Tom's Avatar
 
Join Date: Dec 1999
Location: Mesa AZ
Posts: 4,677
Re: 96 Silverado - Miss at hwy speed

My 98 has done this for the last 100,000 miles. Its random and doesn't do it every drive. Never sets a code. Have pulled distributor to check gear, new fuel pump when old went out, tune ups etc. Have great fuel pressure. Never have figured it out. And yes mine is always at a steady rate not accelerating. Anyone else in the truck doesn't even notice it happen.
__________________
-78 c10 short/step: 388cid, M20, 5/5 drop, lots more. Playtoy and first vehicle.
-98 c1500 x-cab: 5.7L, 17" rims, 5/6 drop, flowmaster, helper bags,NBS rear disk brakes.
-06 CBR600F4i: 110mph in 2nd at 14,000rpm= happiness.
-02 Suburban 4x4: stock
DISCLAIMER: I cant spell for the life of me.
Tom is offline   Reply With Quote
Old 05-18-2018, 08:51 PM   #14
Kudzupatch
Registered User
 
Kudzupatch's Avatar
 
Join Date: Apr 2013
Location: GUNTERSVILLE
Posts: 466
Re: 96 Silverado - Miss at hwy speed

I had to replace plug wires once and the new set was bad. Took me MONTHS to finally find it and the symptoms were similar It would start missing mostly at idle or low load and sometimes at highway. I assumed it was something else since the wires were new. Coming back from a trip it started to get really bad and when I popped the hood I could hear it arcing or I would have never found it I don't think.

Not saying that is your problem, just something to keep in mind.
Kudzupatch is offline   Reply With Quote
Old 05-19-2018, 11:56 AM   #15
likaroc13
Rollin' Old Skool
 
Join Date: Jun 2007
Location: Spring Hill, TN
Posts: 5,020
Re: 96 Silverado - Miss at hwy speed

Quote:
Originally Posted by Tom View Post
My 98 has done this for the last 100,000 miles. Its random and doesn't do it every drive. Never sets a code. Have pulled distributor to check gear, new fuel pump when old went out, tune ups etc. Have great fuel pressure. Never have figured it out. And yes mine is always at a steady rate not accelerating. Anyone else in the truck doesn't even notice it happen.
Sounds exactly like mine. Weird thing is mine never did it before the distributor & fuel pump/sending unit were replaced. I tried watching the instrument cluster but couldn't see any fluctuations when it happened the last time.
__________________
_____________________________________________
Phillip

My Build threads:
1966 Chevy C-10 "Black Betty"

shortbed, fleetside, BBW, 327 V8/ Powerglide (under construction)
http://67-72chevytrucks.com/vboard/s...ighlight=betty

1997 Chevy Tahoe, 2dr/2wd, mild custom (Daily driver)
http://67-72chevytrucks.com/vboard/s...d.php?t=601142

Pics:
'66 C-10 https://flic.kr/s/aHsjHWD4h9
'97 Tahoe https://flic.kr/s/aHsjGZ7wKP
'93 C-1500 https://flic.kr/s/aHskxdpdnQ
'88 S-10 Blazer https://flic.kr/s/aHsjYGx4Md

Previous Rides:
1993 Chevy S-10 ext. cab, 4.3L, 4/5 drop (Sold)
1993 Chevy C-1500 short/step Retro-Rod (Sold)
1988 S-10 Blazer 2dr/2wd mild custom (Sold)
likaroc13 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com