The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 99-06 Chevy and GMC Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 06-28-2018, 02:08 PM   #1
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
99 K1500 Suburban no high speed ac fan

I hope I'm on the correct year group for this as I realize the 99 Trucks had already switched to the 5th gen body style, yet the burbs lagged a year, so this is a 4th gen body.

This isn't a daily driver anymore so it hasn't been a priority, but I'd like to get it working right. Several years ago I had an issue with the hvac system and I replaced a few parts. It started working again, but the high speed doesn't blow and hasn't since. I just don't recall what I replaced at the time...seems like blower at that time. I know I've replaced the blower resistor and possibly even the relay, but not 100% sure on the relay.

I had someone mention maybe a bad ground to relay and/or resistor and they said if you ground it out to chassis, that's a good quick test. Problem is I don't know which wire to ground or which part. On the relay, I'm guessing it's the black wire going into the 5 wire blower motor relay???

My understanding is the resistor only comes into play for the 1-3 fan speeds and the 4 speed bypasses it. If this is correct I'm guessing I can ignore this piece. Then it seems the relay is mainly for the high speed, BUT if I unhook it, none of the speeds work....makes since, but just pointing out. As for the fan, is it possible I have the wrong blower? It's a VDO PM149 and it seems to cross just fine with my 1999 K1500 Suburban 5.7L LT.

Any ideas or suggestions where to turn?

For what it's worth the relay is a Siemens 12193601. Could it be the control unit? I also checked the wires at the blower and they seem fine....if I unhook nothing works and only two wires that I see.
MASTERBrian is offline   Reply With Quote
Old 06-28-2018, 02:56 PM   #2
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

You are correct the the resistor only affects speeds 1-3. High is controlled by the relay. Most likely the relay is the problem. If you lower the glovebox, you should be able to see the relay hiding up there. It sounds like you already found it.

There is a small chance(less than 5%) that the problem is in the switch. I've replaced a decent amount of relays in these trucks.

In the future, you will probably get a better response in the 88-98(gmt400) section.
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 06-28-2018, 02:57 PM   #3
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

Wiring diagram:

Name:  IMG_5795.jpg
Views: 45
Size:  22.9 KB
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 06-28-2018, 03:15 PM   #4
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

I'll try the relay then, it's cheaper than a switch.

Thanks, I thought about posting in that group....
MASTERBrian is offline   Reply With Quote
Old 06-28-2018, 03:51 PM   #5
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

Yea. It gets interesting with the overlapping years. Try and go by body style.
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 06-28-2018, 03:54 PM   #6
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

At store buying switch, if that doesn't solve the n do I buy the control or look more? I saw several Google posts about wiring melting but I think that pertains more to the 5th gen body style. Everything wiring looks good from what I've seen.
MASTERBrian is offline   Reply With Quote
Old 06-28-2018, 04:04 PM   #7
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

The restistors/wiring is super common on the 99-07 trucks, especially he 03-07.

I am fairly sure the relay will fix it. But if it doesn't, I would start checking wires, the control units are 130 online, about 160 in stored.
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 06-28-2018, 06:31 PM   #8
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

1st store didn't have the BW, so I bought the Master Pro? and though it appeared correct, it wouldn't go into the plug. Stopped at another store, returned the Master Pro and bought the BW, it went in easily but no change and thus still no high fan setting.

The guy that told me how to test the ground is working on the AC on my other burb on friday, but I might see him tonight as well and I'll have this truck so I'll see what he says about that.

$20 was not a big deal for a Throw Money at It attempt of a fix. The $130-$200 for the control unit is a bit tougher pill to swallow. I might yank the controls out tonight and see if I can figure anything out. I've inspected the wires but I'll get the diagram printed and see what I find out from that as well.

Thanks again.
MASTERBrian is offline   Reply With Quote
Old 06-28-2018, 06:42 PM   #9
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

I also just noticed/remembered that the ac light on the control doesn't seem to light or at least stay lit, but it does blow cold up front and the rear controls work just fine.
MASTERBrian is offline   Reply With Quote
Old 06-28-2018, 08:37 PM   #10
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

I'm having trouble reading the diagram, am I correct the Orange wire is the high speed wire?

I've done countless repairs since buying this in 2005 and can't remember everything I did and what was done prior, but I'll take credit...good/bad. That said it appears the tabs broke on the control module fan speed selector and I epoxied it back in place. It also seems the plug was replaced as it is spliced. The wires are heat shrank together and since I think I did the repair I would have soldered the wires. Maybe there is an open in them and thus no current. I'll try to check that.

The other fun part is when I search this control unit, the compatible list does not include my truck yet this is what's in there. Maybe that's why I have yet to replace it. Maybe I'll check salvage for a cheap donor.
Attached Images
  
MASTERBrian is offline   Reply With Quote
Old 06-29-2018, 11:27 AM   #11
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

I'm gonna try again here. Name:  IMG_5796.jpg
Views: 36
Size:  70.2 KB
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 06-29-2018, 11:30 AM   #12
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

You are correct. You should have 12v at the orange wire from the blower switch to the control side of the relay(when the key is on and the switch is on high speed).
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 06-29-2018, 11:32 AM   #13
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

Much nicer. I really appreciate it.

It does appear the Orange is the high speed wire. If I'm correct, then shouldn't that wire put out voltage when on high? If no voltage I'd assume this past of control unit is bad, if voltage present I'd assume somewhere else.
MASTERBrian is offline   Reply With Quote
Old 06-29-2018, 12:24 PM   #14
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

Yes. You should have 12v at the orange wire with the key on and the switch on high.
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 06-29-2018, 03:34 PM   #15
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

I get voltage at the relay, can here it click on/off and still no high. There is a red, black, blue, purple and Orange wire at the relay. The red is constant 12v, black ground, blue had power but don't recall when. Orange went hot when high turned on, purple was hot on lower settings and lost power when turned to high.

Is it possible this is purely the fan? A list ground as my mechanic friend seems to think? Or something else?
MASTERBrian is offline   Reply With Quote
Old 06-29-2018, 05:00 PM   #16
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

Check the big 50A fuse in the underhood fuse/relay box.
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 07-02-2018, 04:22 PM   #17
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

Did you get a chance to check the fuse yet?
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 07-05-2018, 11:55 PM   #18
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 571
Re: 99 K1500 Suburban no high speed ac fan

Quote:
Originally Posted by 95 S_Trucker View Post
Did you get a chance to check the fuse yet?
Just realized I forgot to reply. Yes, I checked all the fuses and the relay. Still no high speed. Hoping to get out and try to check the ground wire to the relay behind glove box and possibly at blower.
MASTERBrian is offline   Reply With Quote
Old 07-06-2018, 08:24 AM   #19
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

The ground is ok for the relay and the blower motor.

The relay wouldn't click if it wasn't grounded

The blower wouldn't work at lower speeds if it wasn't grounded


Do you have power at the red wire at the relay? I am going to guess you don't. If you do, your new relay is bad.
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Old 07-06-2018, 08:38 AM   #20
95 S_Trucker
Senior Member
 
95 S_Trucker's Avatar
 
Join Date: Oct 2009
Location: Lancaster, PA
Posts: 1,928
Re: 99 K1500 Suburban no high speed ac fan

Check the area circled in red. It should have 12v. Your symptoms tell me you don't have 12v at the A2 terminal at the relay. It's the only red wire at the relay.

Name:  IMG_5803.jpg
Views: 22
Size:  71.9 KB
__________________
-99 K2500 LS CCSB 7.4
-11 GMC 2500HD SLE CCSB 6.0
-96 C3500 HD 7.4 NV4500 Rollback
-85 K10 5.7 700r4
-78 K10 5.7 4 Speed
-90 ZR1 5.7 6 Speed
-62 Lincoln Sedan 430 Auto
-61 Lincoln Convertable 430 Auto


85 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=368864

78 Big10 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=383629

96 Project: http://67-72chevytrucks.com/vboard/s...d.php?t=614515
95 S_Trucker is online now   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:34 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com