The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Engine & Drivetrain > LSx Swaps

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 08-28-2019, 11:25 AM   #26
prodjay10
Registered User
 
Join Date: Jun 2016
Location: Phoenix AZ
Posts: 274
Re: Vintage Air Top Mount Squeal

Ict has 2 recommendations for belt using stock accessories depending on amperage of alternator.
Posted via Mobile Device
prodjay10 is offline   Reply With Quote
Old 10-04-2019, 01:16 AM   #27
1970 CST Short Wide
Senior Moment
 
1970 CST Short Wide's Avatar
 
Join Date: Mar 2002
Location: Pittsburg Ca
Posts: 2,990
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by 04ls1gto View Post
I'll have to check tension on mine, sounds like they want it tight
Me to, I have the Kwik mount and just today it started to squeal. Belt dressing helped but it’s not the answer
Thanks for the Part #
__________________
1970 CST LS 1 6 speed Ford 9 inch Detroit Locker, Dakota Didgital. Lots of FUN
2013 GMC PU, Oldest Son
1969 Step Side Oldest Sons new Toy
2019 GMC Diesil Dually. Youngest Son
2017 Toyota SUV Daughters ride
2018 Traverse , Wifeís Truck
Pittsburg Ca
94565

Last edited by 1970 CST Short Wide; 10-04-2019 at 12:49 PM.
1970 CST Short Wide is offline   Reply With Quote
Old 10-05-2019, 09:05 AM   #28
65blackfleetside
Active Member
 
65blackfleetside's Avatar
 
Join Date: Nov 2015
Location: Central Florida
Posts: 189
Re: Vintage Air Top Mount Squeal

I had to purchase a laser alignment tool to fix my belt alignment issue.
My serpentine belt kept walking. with this I was able to solve the problem:

https://www.amazon.com/Gates-91006-S...0280585&sr=8-2
__________________
current ride 1951 AD Chevy 5 window 2004 LS Gen 3 [/B]
1965 fleetside Sold
65blackfleetside is offline   Reply With Quote
Old 10-05-2019, 09:40 PM   #29
87chevy.com
Registered User
 
87chevy.com's Avatar
 
Join Date: Feb 2004
Location: Houston, Texas
Posts: 987
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by cebra View Post
Belt squeal issue resolved: I removed the tensioner shim and put in a shorter belt that Kwik recommended after calling. The part number is Gates K061115 and it 1" shorter than what they recommended in the instructions. My tensioner on the previous belt was completely released and the belt wasn't very tight, this one I had to pry the belt on to the tensioner with a screwdriver when installing.
Sounds like it's too tight.. what does the marks on the tensioner show?
__________________
1987 Silverado - L83 5.3 w/ 6L80e ,A/C,P/W,P/L,TILT, HID projectors, Wilwood C-10 Pro Spindles w/ 2018 silverado front brakes & C-5 Corvette Rear Disc Brakes
1999 BMW 528i - 5.7 LS1 w/ 4l60e, Ford 8.8 IRS w31 spline posi & FX-r projector retrofit
A poor man buy's it twice
87chevy.com is offline   Reply With Quote
Old 10-09-2019, 12:00 AM   #30
Scott2
Registered User
 
Join Date: Mar 2015
Location: Castle Rock, CO
Posts: 448
Re: Vintage Air Top Mount Squeal

Mine is squealing as well. It just started and I think the belt stretched and is now slightly long so the tensioner is almost to the stop. This appears to allow the belt to rub against itself on the idler pulley above it. Just picked up a shorter belt today to try.
__________________
Scott

______________
my '51 build: http://67-72chevytrucks.com/vboard/s...d.php?t=677979
Scott2 is offline   Reply With Quote
Old 10-09-2019, 12:09 AM   #31
87chevy.com
Registered User
 
87chevy.com's Avatar
 
Join Date: Feb 2004
Location: Houston, Texas
Posts: 987
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by Scott2 View Post
Mine is squealing as well. It just started and I think the belt stretched and is now slightly long so the tensioner is almost to the stop. This appears to allow the belt to rub against itself on the idler pulley above it. Just picked up a shorter belt today to try.
You got a picture of the setup? Tensioner marks?
__________________
1987 Silverado - L83 5.3 w/ 6L80e ,A/C,P/W,P/L,TILT, HID projectors, Wilwood C-10 Pro Spindles w/ 2018 silverado front brakes & C-5 Corvette Rear Disc Brakes
1999 BMW 528i - 5.7 LS1 w/ 4l60e, Ford 8.8 IRS w31 spline posi & FX-r projector retrofit
A poor man buy's it twice
87chevy.com is offline   Reply With Quote
Old 10-09-2019, 06:23 AM   #32
65blackfleetside
Active Member
 
65blackfleetside's Avatar
 
Join Date: Nov 2015
Location: Central Florida
Posts: 189
Re: Vintage Air Top Mount Squeal

If it makes you feel any better I started off with a Kwik front accessory set up. None of it fit correctly. Sent it back. I am on my 3rd or 4th ICT set up. ICT dropped the ball with me 2x's They were way out of alignment on kit 3 that they sent me. These serp belts will walk if they are out of alignment by 1-2mm.
If I were to build another one of these trucks I would look for a different supplier. Although not the prettiest- The OEM GM accessory brackets are the most proven and reliable. I would bet that GM spent more $ on R&D than all of these after market companies combined?

- Had I mounted the motor another 3" higher I probably could have used all of the OEM brackets .
__________________
current ride 1951 AD Chevy 5 window 2004 LS Gen 3 [/B]
1965 fleetside Sold
65blackfleetside is offline   Reply With Quote
Old 10-14-2019, 10:31 PM   #33
Scott2
Registered User
 
Join Date: Mar 2015
Location: Castle Rock, CO
Posts: 448
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by 87chevy.com View Post
You got a picture of the setup? Tensioner marks?
Hereís a few pics. You can see contact between the belt above the tensioner and the underside of the idler pulley. Thatís with the 114Ē belt recommended by Kwik and the tensioner is almost fully relaxed. The next smaller belt is a 113Ē and I canít get it installed even with the tensioner fully compressed.
Attached Images
   
__________________
Scott

______________
my '51 build: http://67-72chevytrucks.com/vboard/s...d.php?t=677979
Scott2 is offline   Reply With Quote
Old 10-14-2019, 11:49 PM   #34
prodjay10
Registered User
 
Join Date: Jun 2016
Location: Phoenix AZ
Posts: 274
Re: Vintage Air Top Mount Squeal

Have you tried putting the belt on the tensioner, compression it the slipping the belt over a smooth pulley like the water pump?
prodjay10 is offline   Reply With Quote
Old 10-15-2019, 06:24 AM   #35
65blackfleetside
Active Member
 
65blackfleetside's Avatar
 
Join Date: Nov 2015
Location: Central Florida
Posts: 189
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by Scott2 View Post
Hereís a few pics. You can see contact between the belt above the tensioner and the underside of the idler pulley. Thatís with the 114Ē belt recommended by Kwik and the tensioner is almost fully relaxed. The next smaller belt is a 113Ē and I canít get it installed even with the tensioner fully compressed.
Scott,
What is the diameter of that pully? I have a box of idlers and maybe a tensioner or two left over from my projects. I may have a smaller one for you?
__________________
current ride 1951 AD Chevy 5 window 2004 LS Gen 3 [/B]
1965 fleetside Sold
65blackfleetside is offline   Reply With Quote
Old 10-15-2019, 09:48 AM   #36
Scott2
Registered User
 
Join Date: Mar 2015
Location: Castle Rock, CO
Posts: 448
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by prodjay10 View Post
Have you tried putting the belt on the tensioner, compression it the slipping the belt over a smooth pulley like the water pump?
Good point - need to work that approach again. Started trying that - it's very tight then ran out of time! Daughter showed up with her car, my son just got a little Civic - and everyone needed something! Plus I started a Jeep J10 LS swap and general updating project for my son (under alternate tinkerings) but he decided that tinkering on cars and trucks isn't really his "thing" and he wanted to drive a car now. So that one is my project alone now. I'll get a friend and another set of hands and try to get that belt on.
__________________
Scott

______________
my '51 build: http://67-72chevytrucks.com/vboard/s...d.php?t=677979
Scott2 is offline   Reply With Quote
Old 10-15-2019, 09:48 AM   #37
Scott2
Registered User
 
Join Date: Mar 2015
Location: Castle Rock, CO
Posts: 448
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by 65blackfleetside View Post
Scott,
What is the diameter of that pully? I have a box of idlers and maybe a tensioner or two left over from my projects. I may have a smaller one for you?
I'll check - thanks!
__________________
Scott

______________
my '51 build: http://67-72chevytrucks.com/vboard/s...d.php?t=677979
Scott2 is offline   Reply With Quote
Old 10-15-2019, 10:28 AM   #38
cebra
Senior Member
 
Join Date: Jan 2018
Location: Durham, North Carolina
Posts: 576
Re: Vintage Air Top Mount Squeal

...and my belt squeal is back, this is by far the most frustrating piece of my build. Took the bracket off, remounted it using the "resolve the squeal" instructions from Kwik and fingers crossed it isn't squealing but I have had this thing off and on so many times, changed belts, shimmed every way imaginable, changed tensioners and the squeal ALWAYS comes back.
__________________
My Daily Driver Build: http://67-72chevytrucks.com/vboard/s...d.php?t=755668
cebra is offline   Reply With Quote
Old 10-15-2019, 10:32 AM   #39
cebra
Senior Member
 
Join Date: Jan 2018
Location: Durham, North Carolina
Posts: 576
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by Scott2 View Post
Hereís a few pics. You can see contact between the belt above the tensioner and the underside of the idler pulley. Thatís with the 114Ē belt recommended by Kwik and the tensioner is almost fully relaxed. The next smaller belt is a 113Ē and I canít get it installed even with the tensioner fully compressed.
The directions from Kwik say to replace the tensioner pulley with a smooth pulley. From VA, mine came with a tensioner with the smooth pulley already installed. May help you but who knows, every change I make seems to temporarily fix the issue and it keeps returning.
__________________
My Daily Driver Build: http://67-72chevytrucks.com/vboard/s...d.php?t=755668
cebra is offline   Reply With Quote
Old 10-15-2019, 09:06 PM   #40
Scott2
Registered User
 
Join Date: Mar 2015
Location: Castle Rock, CO
Posts: 448
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by prodjay10 View Post
Have you tried putting the belt on the tensioner, compression it the slipping the belt over a smooth pulley like the water pump?
This approach worked! It was tough getting it on the water pump and I had to take it off the new Kwik idler pulley first and then pry it back on after it was on the water pump pulley. Works and no squeak! Thereís room now between the pulleys. Thanks!
Attached Images
  
__________________
Scott

______________
my '51 build: http://67-72chevytrucks.com/vboard/s...d.php?t=677979
Scott2 is offline   Reply With Quote
Old 10-16-2019, 01:59 PM   #41
87chevy.com
Registered User
 
87chevy.com's Avatar
 
Join Date: Feb 2004
Location: Houston, Texas
Posts: 987
Re: Vintage Air Top Mount Squeal

Still out of normal range.



A slightly smaller.beltnor a slightly larger idle pulley.
__________________
1987 Silverado - L83 5.3 w/ 6L80e ,A/C,P/W,P/L,TILT, HID projectors, Wilwood C-10 Pro Spindles w/ 2018 silverado front brakes & C-5 Corvette Rear Disc Brakes
1999 BMW 528i - 5.7 LS1 w/ 4l60e, Ford 8.8 IRS w31 spline posi & FX-r projector retrofit
A poor man buy's it twice
87chevy.com is offline   Reply With Quote
Old 10-16-2019, 03:03 PM   #42
prodjay10
Registered User
 
Join Date: Jun 2016
Location: Phoenix AZ
Posts: 274
Re: Vintage Air Top Mount Squeal

I wonder if you need a relocation kit for one of the pulleys. Ict says if I use factory accessories and the factory alternator mount, then Iíd need a relocation kit for an idler.
prodjay10 is offline   Reply With Quote
Old 10-17-2019, 02:06 PM   #43
Scott2
Registered User
 
Join Date: Mar 2015
Location: Castle Rock, CO
Posts: 448
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by 87chevy.com View Post
Still out of normal range.



A slightly smaller.beltnor a slightly larger idle pulley.
Hmmm - I suppose that's correct, however, it works, makes no noise, and it was a pain to get the belt on there so I will wait this one out and see how it goes. I do appreciate the observation though!
__________________
Scott

______________
my '51 build: http://67-72chevytrucks.com/vboard/s...d.php?t=677979
Scott2 is offline   Reply With Quote
Old 11-11-2019, 10:10 AM   #44
cebra
Senior Member
 
Join Date: Jan 2018
Location: Durham, North Carolina
Posts: 576
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by Scott2 View Post
This approach worked! It was tough getting it on the water pump and I had to take it off the new Kwik idler pulley first and then pry it back on after it was on the water pump pulley. Works and no squeak! There’s room now between the pulleys. Thanks!
What belt and tensioner are you using? I put a new alternator on mine as I thought it may have bearing issues....belt squeal just got louder. Thus far I have tried 2 different tensioners, 2 belts (Gates K061115-111.29" and K061123-112.37") and I just ordered K061120-111.99" as 1123 is too long (squeal on acceleration) and K061115 is too short (had to pry on and it squealed constantly), and more shims and adjustments than I can even recall. I still think the tensioner is too weak for such a long belt, I can move it by hand. My Audi 4 banger has a much more robust tensioner and the original GM tensioner for the long belt was very robust. I have over 20 hours and $150 in belts/tensioners in trying to get this thing to work.

On a side note, every time I request a refund from Vintage Air they send me to Kwik. The Kwik folks said they had a new prototype to fix issues and would send me one but never have. I am getting pretty annoyed that VA keeps sending me to Kwik when VA is the one that sold me the kit.
__________________
My Daily Driver Build: http://67-72chevytrucks.com/vboard/s...d.php?t=755668

Last edited by cebra; 11-11-2019 at 11:16 AM. Reason: update inquiry
cebra is offline   Reply With Quote
Old 11-11-2019, 10:57 AM   #45
YoungPup1977
Account Suspended
 
Join Date: Jun 2015
Location: No longer here
Posts: 1,000
Re: Vintage Air Top Mount Squeal

Quote:
Originally Posted by cebra View Post
What belt are you using? I put a new alternator on mine as I thought it may have bearing issues....belt squeal just got louder. Thus far I have tried 2 different tensioners, 2 belts (Gates K061115-111.29" and K061123-112.37") and I just ordered K061120-111.99" as 1123 is too long (squeal on acceleration) and K061115 is too short (had to pry on and it squealed constantly), and more shims and adjustments than I can even recall. I still think the tensioner is too weak for such a long belt, I can move it by hand. My Audi 4 banger has a much more robust tensioner and the original GM tensioner for the long belt was very robust. I have over 20 hours and $150 in belts/tensioners in trying to get this thing to work.

On a side note, every time I request a refund from Vintage Air they send me to Kwik. The Kwik folks said they had a new prototype to fix issues and would send me one but never have. I am getting pretty annoyed that VA keeps sending me to Kwik when VA is the one that sold me the kit.
Can you provide a few pics of your setup ?
YoungPup1977 is offline   Reply With Quote
Old 11-12-2019, 01:27 PM   #46
cebra
Senior Member
 
Join Date: Jan 2018
Location: Durham, North Carolina
Posts: 576
Re: Vintage Air Top Mount Squeal

If anyone has successfully got the Kwik LS Top Mount AC Bracket to work, could you please post your setup (belt, tensioner, engine, alternator amperage)? Right now I have 40+ hours invested, 4 belts, 2 tensioners, 2 alternators, and paid a shop for 2 hours labor and she is still squealing. I have so much time and money into this now I would like to get it figured out but if anyone else has a top bracket that actually works post that too please. I know of Dirty Dingo, ICT, and Alan Grove but see folks are having issues with ICT as well.
__________________
My Daily Driver Build: http://67-72chevytrucks.com/vboard/s...d.php?t=755668
cebra is offline   Reply With Quote
Old 11-12-2019, 02:38 PM   #47
MDPotter
Registered User
 
MDPotter's Avatar
 
Join Date: Aug 2018
Location: Western Colorado
Posts: 414
Re: Vintage Air Top Mount Squeal

For what it's worth, here is the setup on my dad's:
-Gen 4 5.3 out of a 2012 Silverado
-Amp: unknown, remained stock
-Kwik setup - part #141808 from Vintage Air
-Tensioner: 2002 Z28 (GM
-Belt: Gates K061140

His had the same squeal. He took it to a local shop that has experience with these systems and they did some shimming that helped a little, but didn't fix it. It has faded out over time.

I'm not sure what I'll do on mine - I might try the low mount setup if I have room. I suggested the high mount setup to my dad because it's easier to access but I'm not sure I want to take the gamble on mine.
__________________
1968 GMC C15 - Gen III 6.0 Restomod in progress http://67-72chevytrucks.com/vboard/s...d.php?t=772047
1964 Chevy C10 - Gen IV 5.3 Restomod http://67-72chevytrucks.com/vboard/s...d.php?t=768632
2016 Sierra 1500 All Terrain SLT - 33's, leveling kit, muffler delete
MDPotter is offline   Reply With Quote
Old 11-27-2019, 02:42 PM   #48
TA_C10
Registered User
 
Join Date: Jun 2018
Location: Texas
Posts: 550
Re: Vintage Air Top Mount Squeal

Jeez. I found your thread... I will let you know what happens with mine... This sounds painful...
__________________
TA_C10 Stage 1 build - http://67-72chevytrucks.com/vboard/s....php?p=8333444

"It's only money".
TA_C10 is offline   Reply With Quote
Old 11-27-2019, 02:47 PM   #49
04ls1gto
Registered User
 
Join Date: Aug 2014
Location: Portsmouth ri
Posts: 310
Re: Vintage Air Top Mount Squeal

I have struggled with the same belt issues and am thinking of trying the Holley AC bracket to see if it fixes issue. Has anyone changed bracket to a different brand?
04ls1gto is offline   Reply With Quote
Old 11-27-2019, 03:35 PM   #50
cebra
Senior Member
 
Join Date: Jan 2018
Location: Durham, North Carolina
Posts: 576
Re: Vintage Air Top Mount Squeal

Yeah, this is the most frustrating issue I have ever deal with in my 20 years of working on cars as just when you think you may have found the right combination of alternators, belts, tensioners, ac bracket configuration, and ps pump....bam, it starts squealing again. I just got another updated bracket from Kwik I plan to put on this weekend and if that doesn't fix it I will return it and go with Alan Grove which looks to be a more robust design. I have not heard of anyone having success with this bracket thus far but please post if you figured it out; the crazy thing is Kwik/VA say they rarely see anyone with issues with this bracket. I have a collection at this point of 4 belts, 3 alternators, 2 ps pumps, 2 tensioners, and 2 ac brackets to try and find the right combination that gets the junk tensioner in its tension range (1/2" longer belt goes from too tight to too loose; one you have to pry on with a screwdriver and the other you can pull off with the tensioner released).
__________________
My Daily Driver Build: http://67-72chevytrucks.com/vboard/s...d.php?t=755668
cebra is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:19 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com