The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > Info Center > FAQ Truck Tech > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 09-30-2016, 01:08 PM   #1
Shellyarrowsmith
Registered User
 
Shellyarrowsmith's Avatar
 
Join Date: May 2015
Location: Courtenay, BC canada
Posts: 14
Question backfeed no dash lights when headlights on

My dash cluster does not light up when headlights are on my 69 Chevy C10. When my headlights are on the turn signal indicator lights light up both when signal is flashing. Looks similar to Hazard light up. My high beam light indicator is illuminated as well. One bulb lights very softly on the speedo but no others.

The headlights (Hi/low beam), taillights and turn signals function correctly, however the dash does not.

I have power at the dash cluster grey wire. Good ground on the dash cluster wiring. I have power to the heater control light but no light.


So far I have done the following:

Replaced headlight switch.

checked both power and ground to dash cluster wiring (good)

Eliminated sections of wiring by unplugging back wiring harness unplugging each headlight and then marker lights with same issue.

Any thoughts would be appreciated I am going to clean up all grounds this morning and see if it helps next step is to remove backing panel to the dash and test.

Last edited by Shellyarrowsmith; 09-30-2016 at 01:15 PM.
Shellyarrowsmith is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com