The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1988 - 1998 GMT400 Chevy & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 06-02-2015, 09:14 AM   #1
oldblue92
Registered User
 
oldblue92's Avatar
 
Join Date: Feb 2011
Location: sterling heights michigan
Posts: 55
Turn Signals not working!

Hi guys its been a min since my last post but I need some help. I recently bought a 1989 silverado 4x4 single cab. the other day the turn signals stopped working. The Hazards work fine and i can here the relay clicking. But even when I click the indicator lever the light does not appear on the dash or outside lights. Any advice in the right direction would be great thanks a bunch guys!
oldblue92 is offline   Reply With Quote
Old 06-02-2015, 02:37 PM   #2
green_grenade
Registered User
 
green_grenade's Avatar
 
Join Date: Mar 2015
Location: Gilbert AZ
Posts: 26
Re: Turn Signals not working!

I would try and find the wiring down in the steering column and see if you are getting anything out of the switch at all.
green_grenade is offline   Reply With Quote
Old 06-02-2015, 09:35 PM   #3
Cape Codder
Registered User
 
Cape Codder's Avatar
 
Join Date: May 2013
Location: Centerville,Ma.
Posts: 1,219
Re: Turn Signals not working!

The turn signal flasher could be bad.
Cape Codder is offline   Reply With Quote
Old 06-04-2015, 10:30 AM   #4
oldblue92
Registered User
 
oldblue92's Avatar
 
Join Date: Feb 2011
Location: sterling heights michigan
Posts: 55
Re: Turn Signals not working!

Are the Hazard's and turn signals on the same relay?
oldblue92 is offline   Reply With Quote
Old 06-04-2015, 03:44 PM   #5
Powar
Registered User
 
Powar's Avatar
 
Join Date: Sep 2009
Location: Shepherdsville, KY
Posts: 9
Re: Turn Signals not working!

Quote:
Originally Posted by oldblue92 View Post
Are the Hazard's and turn signals on the same relay?
There are two flasher modules. One runs the hazards and one runs the turn signals.
__________________
'94 Suburban C2500HD 6.5TD
Powar is offline   Reply With Quote
Old 04-10-2016, 07:46 PM   #6
harricanfloyd
Registered User
 
Join Date: Feb 2016
Location: ma
Posts: 28
Re: Turn Signals not working!

men, we need to follow up with actual problem fixes.. We don't know if you got them working or not lol
harricanfloyd is offline   Reply With Quote
Old 06-10-2019, 02:57 PM   #7
Suburban Steve
Junior Member
 
Suburban Steve's Avatar
 
Join Date: Jun 2018
Location: Ripon, Ca
Posts: 42
Re: Turn Signals not working!

I know this is an ANCIENT post BUT it is exactly what my 92 2dr Blazer/Tahoe is doing Hazards are fine... No blinkers... no click no indicators etc.... someone says 2 different flashers.... where is the flasher for the blinkers?

Thank in advance for any response that is helpful.
Suburban Steve is offline   Reply With Quote
Old 06-10-2019, 05:36 PM   #8
ChevyTech
Registered User
 
Join Date: May 2004
Location: Minnesota
Posts: 4,463
Re: Turn Signals not working!

Quote:
Originally Posted by Suburban Steve View Post
I know this is an ANCIENT post BUT it is exactly what my 92 2dr Blazer/Tahoe is doing Hazards are fine... No blinkers... no click no indicators etc.... someone says 2 different flashers.... where is the flasher for the blinkers?

Thank in advance for any response that is helpful.
The turn flasher is in the bottom left corner of the Convenience Center, which is just to the right of the park brake assembly.
__________________
For those of you that are wondering why you are not getting replies to your thread:
Did you give the model, year, engine, fuel system type, and transmission information?
If it is modified from what came stock from the factory, let us know that too.
ChevyTech is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:48 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com