The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 04-16-2018, 01:09 PM   #1
Baketown Scotty
Junior Member
 
Baketown Scotty's Avatar
 
Join Date: Oct 2005
Location: Bakersfield, CA
Posts: 264
Front Turn Signal Problem

Trying to get all lights on 1966 GMC working to get it registered. All work except the front turn signals and parking lights. My test light lights up at the firewall, where the socket connects to the wiring and when I touch the metal sockets. It seems I have power the whole way but the bulbs won't light. I have new bulbs and have tried both 1157 and 1147. What am I missing?
__________________
1969 K5 Blazer
1964 Chevy Suburban 4x4
1966 GMC Suburban 4x4
Baketown Scotty is offline   Reply With Quote
Old 04-16-2018, 04:51 PM   #2
VetteVet
Msgt USAF Ret
 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,064
Re: Front Turn Signal Problem

you should have three wires to your lights. A purple one to both lights, a light blue one for the left turn signal and a dark blue one for the right turn signal.

If you have power on your wires then lack of ground could be your problem especially since the lights are in the hood. It may not be getting ground to the cab and back to the negative side of the battery. Try running a jumper wire from the battery negative battery terminal to one of the light sockets the with the parking lights on. If you get a light then the hood hinge is not grounding to the cab or the cab is not grounding to the battery.

You might test it with your test light by connecting the light socket and the negative battery terminal. If you light doesn't come on then there is no ground connection between the hood and the cab.
__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Old 04-17-2018, 02:31 PM   #3
Baketown Scotty
Junior Member
 
Baketown Scotty's Avatar
 
Join Date: Oct 2005
Location: Bakersfield, CA
Posts: 264
Re: Front Turn Signal Problem

Thank you for your reply Sir. I will try that this weekend when I get home. I appreciate it.
__________________
1969 K5 Blazer
1964 Chevy Suburban 4x4
1966 GMC Suburban 4x4
Baketown Scotty is offline   Reply With Quote
Old 04-25-2018, 07:25 PM   #4
Baketown Scotty
Junior Member
 
Baketown Scotty's Avatar
 
Join Date: Oct 2005
Location: Bakersfield, CA
Posts: 264
Re: Front Turn Signal Problem

Not having a good ground was the issue. They all work well with the proper ground.
__________________
1969 K5 Blazer
1964 Chevy Suburban 4x4
1966 GMC Suburban 4x4
Baketown Scotty is offline   Reply With Quote
Old 04-25-2018, 11:36 PM   #5
VetteVet
Msgt USAF Ret
 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,064
Re: Front Turn Signal Problem

Quote:
Originally Posted by Baketown Scotty View Post
Not having a good ground was the issue. They all work well with the proper ground.





__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:39 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com