The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 04-13-2019, 10:18 AM   #1
72step
Registered User
 
72step's Avatar
 
Join Date: Nov 2000
Location: chimayo, nm, usa
Posts: 895
Gauges not working

I got an 85 chevy k10 that was somewhat back together after a restoration and the vitals gauges i cant get working. Fuel gauge and speedo work fine.
72step is offline   Reply With Quote
Old 04-14-2019, 11:59 PM   #2
WyattTX
Registered User
 
Join Date: Nov 2015
Location: Down south
Posts: 378
Re: Gauges not working

Use a test light on the voltmeter gauge, if power is running to it, and you have a ground, your guage is likely broken. Make sure the Engine temp guage is grounded and the wire runs to the temp sending unit. I don't remember how the oil pressure guage works on these, so you may have to take a look at some wiring diagrams. While you look at wiring diagrams, make sure everything is in the correct place, and once again verify everything is grounded. It can get frustrating, but be patient these old trucks are simple enough.
WyattTX is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:23 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com