The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1988 - 1998 GMT400 Chevy & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 09-21-2018, 09:15 PM   #1
bad69
Struggling Artist
 
Join Date: Dec 2003
Location: Battle Ground WA.
Posts: 120
1990 4.3 hesitating

TIA, my 90 C-1500 starts running strange and hesitates under load. The wipers come on ocasionally when it happens, i've replaced the distribtor, computer and ignition switch. Anyone have an idea what it could be?
__________________
69 1/2 ton lwb lowrider
90 C-1500 2wd
08 2500 HD 4WD
94 Grand Cherokee
49 Cadillac sedan
bad69 is offline   Reply With Quote
Old 09-22-2018, 09:05 PM   #2
AussieinNC
Registered User
 
AussieinNC's Avatar
 
Join Date: Jun 2017
Location: Cherryville, NC
Posts: 741
Re: 1990 4.3 hesitating

Locate and clean every vehicle ground strap making sure that both the mount point and the strap itself are really clean...

Loss of grounds will drive systems crazy...

__________________
Family and country before all others...
Thank you to all those who serve to protect our country...

It is such a pleasure on a quiet evening here in Cherryville NC, to hear all those Fords quietly rusting away !
AussieinNC is offline   Reply With Quote
Old 10-04-2018, 11:14 PM   #3
bad69
Struggling Artist
 
Join Date: Dec 2003
Location: Battle Ground WA.
Posts: 120
Re: 1990 4.3 hesitating

Thanks for the info. Cleaned or replaced all ground straps, still having issue. Only starts after it comes off cold idle and under load. SMH
__________________
69 1/2 ton lwb lowrider
90 C-1500 2wd
08 2500 HD 4WD
94 Grand Cherokee
49 Cadillac sedan
bad69 is offline   Reply With Quote
Old 10-05-2018, 08:17 PM   #4
diveplane
Registered User
 
Join Date: Nov 2016
Location: Tulsa
Posts: 298
Re: 1990 4.3 hesitating

Quote:
Originally Posted by bad69 View Post
TIA, my 90 C-1500 starts running strange and hesitates under load. The wipers come on ocasionally when it happens, i've replaced the distribtor, computer and ignition switch. Anyone have an idea what it could be?
ok for your wipers i think its possibly a bad circuit board inside the wiper housing inside engine bay mounted to drivers side firewall. i replaced mine it was a known issue with the trucks and a recall , buy the new boards at orileys.

my issue was they would not come on , the new part did the fix, can also check the wiper relay.
diveplane is offline   Reply With Quote
Old 10-05-2018, 08:21 PM   #5
diveplane
Registered User
 
Join Date: Nov 2016
Location: Tulsa
Posts: 298
Re: 1990 4.3 hesitating

Quote:
Originally Posted by bad69 View Post
Thanks for the info. Cleaned or replaced all ground straps, still having issue. Only starts after it comes off cold idle and under load. SMH
when u say underload general driving? take off from start.

sounds like a weak spark did u replace plugs cables? could be a ignition coil going out weak output.
diveplane is offline   Reply With Quote
Old 10-11-2018, 05:09 PM   #6
andyh1956
Registered User
 
Join Date: Mar 2010
Location: thomastown mississippi
Posts: 1,139
Re: 1990 4.3 hesitating

The very 1st thing to do on ANY GM TBI engine is to cut the ground terminals offa the wires out on the manifold back to good wire, install new terminals & then fasten them to the same stud the battery ground cable goes to on the manifold. Make sure everthing is clean! Get that one ground wire OFF the thermostat housing!
andyh1956 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com