The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1967 - 1972 Chevrolet & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 11-13-2017, 08:42 PM   #1
Lfisablst
Registered User
 
Join Date: Nov 2017
Location: Lake elsinore
Posts: 3
My 70 c20 dies when put in gear

I have a problem with my 70 chevy c20. I put in a lunati barebones cam a jegs manifold and headers. Truck idles great and sounds good. When i put it in gear it dies immediatly. Anybody have a thought on whats going on. Its really driving me crazy. It ran fine before i changed the parts.
Lfisablst is offline   Reply With Quote
Old 11-13-2017, 10:06 PM   #2
Steeveedee
Registered User
 
Steeveedee's Avatar
 
Join Date: Jan 2013
Location: Simi Valley, CA
Posts: 779
Re: My 70 c20 dies when put in gear

Check the timing and look for vacuum leaks. What kind of vacuum does it hold at idle? Could be as simple as adjusting the idle mixture. There isn't much to go on, atm.
__________________
'70 Chevy 3/4T Longhorn CST 400/400/3.54 Custom Camper

"Orange Acres"
Steeveedee is offline   Reply With Quote
Old 11-13-2017, 10:38 PM   #3
Lfisablst
Registered User
 
Join Date: Nov 2017
Location: Lake elsinore
Posts: 3
Re: My 70 c20 dies when put in gear

Replaced the vacuum lines and timing is at 8 degrees advanced. There are 2 screws on the carb. I tightened them completely then backed them out 2 turns. I have it idling at 1000 rpms. What do i need to check the vacuum at idle. Somebody told me i might need to change the torque converter if the cam is to big. I never heard of that before.
Lfisablst is offline   Reply With Quote
Old 11-13-2017, 10:59 PM   #4
allchevy58
Senior Member
 
allchevy58's Avatar
 
Join Date: Aug 2011
Location: Reno, Nv.
Posts: 718
Re: My 70 c20 dies when put in gear

Sounds like it could be running too lean.
__________________
1927 Willy's Knight 24,000 original miles, 1958 Impala 283/Powerglide, 1964 C-30 283/4 speed, 1971 Monte Carlo 350/350, 1972 GMC K2500 350/350, 1976 Chev. K10 350/350, 2002 Subaru VDC 3.0 H6, 2006 Chev. Silverado K3500 LBZ Duramax/Allison
allchevy58 is offline   Reply With Quote
Old 11-13-2017, 11:30 PM   #5
geezer#99
Registered User
 
geezer#99's Avatar
 
Join Date: Aug 2009
Location: Bowser
Posts: 8,888
Re: My 70 c20 dies when put in gear

Quote:
Originally Posted by Lfisablst View Post
Replaced the vacuum lines and timing is at 8 degrees advanced. There are 2 screws on the carb. I tightened them completely then backed them out 2 turns. I have it idling at 1000 rpms. What do i need to check the vacuum at idle. Somebody told me i might need to change the torque converter if the cam is to big. I never heard of that before.
At what rpm did you check your timing?
If at 1000 rpm then the mechanical advance is already kicking in and your 8 degrees might actually be zero or less.
geezer#99 is offline   Reply With Quote
Old 11-13-2017, 11:50 PM   #6
Lfisablst
Registered User
 
Join Date: Nov 2017
Location: Lake elsinore
Posts: 3
Re: My 70 c20 dies when put in gear

Set the timing at 900 rpm. Should it idle lower than that to set my timing.
Lfisablst is offline   Reply With Quote
Old 11-14-2017, 09:29 AM   #7
Marine-58
Registered User
 
Marine-58's Avatar
 
Join Date: May 2017
Location: Parker, CO
Posts: 114
Re: My 70 c20 dies when put in gear

A few things to check. Sorry if this is basic, but not sure of your experience level or what all you have on the engine.

Distributor - if it is points, have you checked the dwell? Made sure the rotor/cap/condensor are all good? If HEI, you certainly don't have to worry about that.

Timing - Set RPM below 1000 as Geezer mentioned. I generally try to not be above 650-700. Remove the vacuum line to the distributor and plug it. Make sure the engine is warmed up and not on fast idle or the choke engaged.

If you are having trouble dropping the RPM, then likely you have either a vacuum or carb issue. Others can surely describe troubleshooting a choke better than I can. Not my area of expertise. Can usually get one running pretty good, but it is trial and error.

For chasing vacuum leaks, of course look for any cracked or missing hoses. For a leak say at the intake gasket or carb gasket - with the engine running, take some wd-40 and spray the gaskets under the carb and along where the intake bolts to the heads. It doesn't take much. If the engine smooths out, you just found your leak. If you have power brakes, take the vacuum line off the booster and plug it as well. Check that the line to the vacuum modulator on the trans hasn't slipped off or is broken.

That is all I can think of right now. Still early here in Denver...

Good Luck...
__________________
72 Chevy C10 383/465

69 Corvette convertible 502/575
Marine-58 is offline   Reply With Quote
Old 11-14-2017, 10:16 AM   #8
geezer#99
Registered User
 
geezer#99's Avatar
 
Join Date: Aug 2009
Location: Bowser
Posts: 8,888
Re: My 70 c20 dies when put in gear

Excellent advice Marine!
I might add that if it won't idle down to 700 rpm, just increase the timing a little at a time until it will idle lower. To do this don't loosen the distributor completely. Leave it a little snug and move it slightly. It likely won't take much.
Then set your timing.
10 degrees is a good place to start.
Your motor might like more but experiment with that later once you get it to stay running when you pop it into gear.

Another thing to remember is the elevation where you live. Just like Marine-58's motor, your motor will be happier with more timing than is usually used at sea level.

Last edited by geezer#99; 11-14-2017 at 10:22 AM.
geezer#99 is offline   Reply With Quote
Old 11-14-2017, 12:29 PM   #9
Wrenchbender Ret
Registered User
 
Join Date: Oct 2005
Location: Lenexa, Kansas
Posts: 4,488
Re: My 70 c20 dies when put in gear

If your vacuum advance is hooked to ported vacuum change it to full manifold vacuum. You may have to get an adjustable vacuum advance unit & adjust it to come on with lower vacuum. With a performance cam you have less vacuum. What are the specks on the cam at .050. & the lift. If you have too radical of a cam it will not work good with an auto. trans. unless you use a high stall converter. They are not pleasant to drive. Your float level in the carb may be too low.
George
Wrenchbender Ret is offline   Reply With Quote
Old 11-14-2017, 05:00 PM   #10
Marine-58
Registered User
 
Marine-58's Avatar
 
Join Date: May 2017
Location: Parker, CO
Posts: 114
Re: My 70 c20 dies when put in gear

Wrenchbender makes a good point. I was reading the original post about a Lunati bare bones cam, thinking it was close to a stock grind. If it is more radical, it can certainly mess with idle. All adjustments become more critical and less forgiving and you do lose vacuum at idle.

You don't mention changing lifters. So I have to ask if the lifter (new or old) were properly adjusted after installing the cam and also if you followed the directions on breaking the in cam.

Aside from this, I just noticed that you set the carb by turning the air adjust screws all the way in and then backing them out two turns. Not knowing what carb you have, you may want to adjust them a little better. I would start with 1 1/2 turn out for each. Disconnect the distributor vacuum and hook up a vacuum gauge. You want to adjust them one at a time for the highest vacuum reading. It takes going back and forth a few times but it can help. IF you are turning the screws in and do not find where the idle drops off or the engine stalls, good chance when you over tightened them, you may have turned them a little hard. It doesn't take much pressure to blunt the ends. At that point you lose you idle air adjustment. Replace them if that is the case. Otherwise, you will never get that setting correct.

As you make adjustments, turn the idle down a little. Keep going back and forth while lowering idle. If it is the carb adjustment, you will get there in a few minutes. After making a couple adjustments, it helps to rev the engine a couple quick times just to make sure it isn't loading up. Be sure to do this with the engine fully warmed up.

Guessing that the cam is not extremely radical, the torque converter is a long shot. I would try everything else before that.
__________________
72 Chevy C10 383/465

69 Corvette convertible 502/575
Marine-58 is offline   Reply With Quote
Old 11-14-2017, 05:18 PM   #11
Coley
Senior Member
 
Coley's Avatar
 
Join Date: Oct 2011
Location: Victoria, B.C
Posts: 2,670
Smile Re: My 70 c20 dies when put in gear

I agree with guys here
1) Advance the timing.....and do this before you touch the carb.
2) Check for vacuum leaks...everywhere. You can put a piece of soft cloth in the jaws of a set of pliers and carefully pinch all of the hoses including the brake booster supply...if the idle improves when you do this on any hose...that item is leaking vacuum.
3) What type of carb?.....
With the quadrajets....most need to be thoroughly cleaned every couple of years to get and keep them working right.
so....is it a quadrajet?


Coley
__________________
....for some men, there is experience, skill and effort....for the others...there is visa and UPS LOL
1966 Chevy 1/2 ton (Florida- Red/white)
1972 Chevy 1/2 ton (California- Blue/white)
2005 Chevy Silverado HD2500/Duramax
2000 Dodge Ram 1500
Coley is offline   Reply With Quote
Old 11-14-2017, 05:54 PM   #12
Marine-58
Registered User
 
Marine-58's Avatar
 
Join Date: May 2017
Location: Parker, CO
Posts: 114
Re: My 70 c20 dies when put in gear

I never thought of pinching off vacuum lines like that. That is what I love about this forum, so many good ideas and many are just common sense things you never think about doing... I was wondering about the carb being a Rochester. Over the years I have known quite a few guys that claim to be good on those things, very few actually were... I'll tackle almost any other carb but not a quadrajet except for easy stuff like this adjustment.
__________________
72 Chevy C10 383/465

69 Corvette convertible 502/575
Marine-58 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com