The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > Info Center > FAQ Truck Tech > 67-72

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 09-26-2019, 10:38 AM   #1
Smitty550
Registered User
 
Join Date: Sep 2016
Location: Santa Rosa, CA
Posts: 9
Wonky Speedometer in '67 C10

The speedometer in my '67 C10 (250CID with TH350 transmission; stock gauges) seems to have developed a "bounce" that appears mostly during the first ten or fifteen miles or so, after which time it starts to operate smoothly.

I would imagine that the cable needs lubing or replacement, or maybe the problem is in the speedometer gauge itself, or maybe at the transmission end.

Should I just bite the bullet and change out the cable for a new one? If I choose this route, should I lube the speedo gauge while I'm at it? Any good videos available on how to solve the problem? Any advice would be appreciated.

Thanks,

Smitty
Smitty550 is offline   Reply With Quote
Old 09-17-2020, 05:54 AM   #2
MAC71Cheyenne
Registered User
 
Join Date: Aug 2020
Location: Mount Pleasant Iowa
Posts: 26
Re: Wonky Speedometer in '67 C10

It may just not be fully seated in the head or transmission. I would try checking both ends first. If that is not an issue removing the cable is not that difficult. Take it out, check the ends for wear, pull the inner cable out, check for kinks, clean, lube, reinstall.
MAC71Cheyenne is offline   Reply With Quote
Old 10-12-2020, 10:18 AM   #3
HotWheelsFan
Junior Member
 
HotWheelsFan's Avatar
 
Join Date: Mar 2010
Location: Oregon
Posts: 50
Re: Wonky Speedometer in '67 C10

In my experience I have found speedo cables needing to be lubed and rust in the speedo head itself...

Easy to lube the cable, the grease gets dry and the inner drive springy wire can jump around a bit till the lube warms up or becomes smooth.

When the speedo head gets rusty it allows the metal drum to come in contact with the magnets. Should be no contact at all - I'm sure you can find more info about the inner workings of a speedo.



When this happens you may be able to hear a tinging or slight bell like sound as the speedo jumps around.

Hope this helps a bit,

Bob
HotWheelsFan is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:32 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com