The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 99-06 Chevy and GMC Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 11-19-2017, 10:54 AM   #1
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 550
2003 'burb front heater not blowing warm

Looking for things to check. Apparently the front heater isn't blowing warm air only cool. I can turn all the way too high seeing and just get cool air. The rear system works great.

I've already recalibrated the blend doors and they seem to be functioning fine. I've felt the lines going to the heater core and they both feel warm, problem is with the rear system those lines T off right near the firewall where the front core resides, so not sure if just residual heat or if it's flowing.

For what it's worth, I moved away from Dexcool years ago. The truck has auto climate control and everything in dash looks to be working fine. The truck has 220k on it.

Best part is I'm on vacation in Colorado, so heat would be nice to figure out.
MASTERBrian is offline   Reply With Quote
Old 11-19-2017, 05:38 PM   #2
Pyro
Registered User
 
Pyro's Avatar
 
Join Date: Jul 2004
Location: New Boston, MI
Posts: 70
Re: 2003 'burb front heater not blowing warm

If you're positive the blend door is working properly and the rear heat is blowing hot then I'd say the only possibility is that the heater core must be plugged. There's not really anything else I can think of that it could be.
Pyro is offline   Reply With Quote
Old 11-19-2017, 07:57 PM   #3
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 550
Re: 2003 'burb front heater not blowing warm

Well, doing some more research it seems like there is a door that controls air movement over the heater core. I'm really leaning that direction as I have heat back at the moment. I've also been hearing an actuator noise for a while, I'm betting that is the noise I've been hearing.

Now time to figure out where it is and how hard replace.
MASTERBrian is offline   Reply With Quote
Old 11-27-2017, 06:07 PM   #4
Ski-me
Registered User
 
Ski-me's Avatar
 
Join Date: May 2012
Location: Colo Springs, CO
Posts: 654
Re: 2003 'burb front heater not blowing warm

Yea, I'd be guessing the actuators are going bad. I've replaced a few up front and also the rears. I'm at 165k so if you're over 200k, they might be due. The front dash ones, I used AC Delco ones because they are harder to get to. Mainly the one in the middle, top side. I had to remove the passenger airbag to gain access to it. The second one is on the floor, between driver and passenger area. A third one is at the air inlet box.

All 3 use same one: GM 89018365 for my 04' with Auto climate control (both front locations).
A fourth one is different....I didn't touch and it's on the side of the truck.

The ones in the back, I used Dorman ones.
__________________
- Jeff

89' K5 Blazer, 2.5" lift, 35" tires
04' GMC Yukon XL, 3/4 ton, 8.1L
Ski-me is offline   Reply With Quote
Old 11-27-2017, 06:10 PM   #5
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 550
Re: 2003 'burb front heater not blowing warm

Quote:
Originally Posted by Ski-me View Post
Yea, I'd be guessing the actuators are going bad. I've replaced a few up front and also the rears. I'm at 165k so if you're over 200k, they might be due. The front dash ones, I used AC Delco ones because they are harder to get to. Mainly the one in the middle, top side. I had to remove the passenger airbag to gain access to it. The second one is on the floor, between driver and passenger area. GM 89018365 for my 04' with Auto climate control.

The ones in the back, I used Dorman ones.
I haven't had a chance to track it down and look into it since getting back into town, but I had found a video showing how to replace the upper dash one, I thought without pulling the airbag, but maybe I'm wrong on that. It has you removing the upper dash pad, handle, etc....now I'm thinking the airbag is in there. Are the airbags a PIA to remove and re-install?

**I forgot to add, someone also had a video about taking a dorman actuator apart to re-build a factory one. Again, I haven't watched that and I haven't studied both, but I'm guessing the Dorman uses cheaper gears and the AC Delco uses nicer ones and that's what you would be robbing from the factory unit(s).

Last edited by MASTERBrian; 11-27-2017 at 06:21 PM.
MASTERBrian is offline   Reply With Quote
Old 11-27-2017, 06:42 PM   #6
Ski-me
Registered User
 
Ski-me's Avatar
 
Join Date: May 2012
Location: Colo Springs, CO
Posts: 654
Re: 2003 'burb front heater not blowing warm

Too bad you're out of Colorado now...could of helped.

The airbag is not hard to do at all, just the "idea" of removing it more than anything. Need to discharge it by disconnecting your vehicle battery for 15-30 minutes. When I pulled it, I tried to be careful and not be in front of it when possible.

The job isn't that bad, just takes some time. I found a step by step process on the web that really helped. Pictures and everything.

I took my actuator apart and honestly, couldn't tell where it was broken. One of mine was making a clicking sound all the time. Annoying really. I just feel a "little better" installing the AC Delco ones because it's a bigger job. The ones in the rear are pretty easy. I also replaced some computer module in the back too. All pretty easy.

I'd install new and skip the rebuild. At a minimum, you could go for the Dorman ones.

I had AC blowing up front and the heat blasting in the rear (in middle of summer).
__________________
- Jeff

89' K5 Blazer, 2.5" lift, 35" tires
04' GMC Yukon XL, 3/4 ton, 8.1L
Ski-me is offline   Reply With Quote
Old 11-27-2017, 06:49 PM   #7
Ski-me
Registered User
 
Ski-me's Avatar
 
Join Date: May 2012
Location: Colo Springs, CO
Posts: 654
Re: 2003 'burb front heater not blowing warm

I see the new GM number is
ACDelco 15-72971

I paid $70.08 each.
__________________
- Jeff

89' K5 Blazer, 2.5" lift, 35" tires
04' GMC Yukon XL, 3/4 ton, 8.1L
Ski-me is offline   Reply With Quote
Old 12-06-2017, 01:39 PM   #8
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 550
Re: 2003 'burb front heater not blowing warm

Quote:
Originally Posted by Ski-me View Post
I see the new GM number is
ACDelco 15-72971

I paid $70.08 each.
Thanks, Right now it's working again and I've been swamped so it's on hold, but I'll be visiting this after the holidays, I'm sure. Sounds like while in there, just replace them all....or at least the most difficult of them.

Also, I really appreciate the offer of help if I had still been in Colorado.
MASTERBrian is offline   Reply With Quote
Old 12-06-2017, 01:53 PM   #9
Ski-me
Registered User
 
Ski-me's Avatar
 
Join Date: May 2012
Location: Colo Springs, CO
Posts: 654
Re: 2003 'burb front heater not blowing warm

No problem. Enjoy your Christmas!!
__________________
- Jeff

89' K5 Blazer, 2.5" lift, 35" tires
04' GMC Yukon XL, 3/4 ton, 8.1L
Ski-me is offline   Reply With Quote
Old 12-28-2017, 05:21 PM   #10
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 550
Re: 2003 'burb front heater not blowing warm

I've had a few minutes today to mess with this some. I pulled the actuator underneath passenger side dash. Without actuator I can move that door freely. I've way I get cold air, the other warmer air....didn't seem as warm as the rear though.

I plugged actuator in, not bolted in place though, and it moved but very, very slowly. With air blowing over the door it's hard to move the door by hand. I don't know if that actuator should move fast or slow. I'm talking, maybe a click every other second slow.

I was thinking I'd back flush the core since it's decent outside today, but it has those push to unlock connectors, not sure if I can easily slide house onto that. Video I watched was a pickup and it looked simple, but with the rear air, it has more fittings. Maybe I'll pay the shop $80 if I go that route. Ugh! Reason is idled truck to get to operating temp and the inlet is hot, the outlet to core is not, BUT it's the same on the rear heat tube.

I'm now trying to figure out exactly what each actuator does. My understanding is that one under dash is recirc, that works. Then the mode, which gives defrost/dash bent and floor works fine, but unsure which one that is. I'm also confused on what the actuator on passenger side lower one controls. Is that driver side temp or driver and passenger? Then what is the one on the drive side floor?
MASTERBrian is offline   Reply With Quote
Old 12-28-2017, 05:31 PM   #11
MASTERBrian
Registered User
 
Join Date: Jan 2017
Location: Wichita
Posts: 550
Re: 2003 'burb front heater not blowing warm

Just looked at another pic and it appears the one on driver side floor is the mode(defrost/dash vent/floor). Then the one far right under dash pad is the recirc. It says the one on passenger floor is the temp door. My only issue is I'm under impression that with the auto temp and his/her controls, I have four actuators. So, is the floor the driver side and then is there another under dash pad, center of dash that controls passenger side? I'm having trouble getting a clear diagram of all of this.
MASTERBrian is offline   Reply With Quote
Old 12-29-2017, 09:16 PM   #12
greasemonkey
Registered User
 
greasemonkey's Avatar
 
Join Date: Dec 2001
Location: Pace, FL
Posts: 2,041
Re: 2003 'burb front heater not blowing warm

You are correct, there are 4. The one on the passenger side over the trans tunnel is the driver side blend door. There is another one buried in the dash for the passenger temp. I haven't had to change that one but there are a few writeups on the internet to follow.
__________________
1942 Master Deluxe
1969 C/10
1985 Blazer CUCV
1987 Jimmy
2004 Tahoe
2005 Silverado
greasemonkey is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com