The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board > The 1973 - 1991 Blazers, Jimmys, and Suburbans Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 01-29-2019, 05:50 PM   #1
snowball
Registered User
 
Join Date: Apr 2012
Location: Texas
Posts: 74
Problem with wiper switch...

Hi all,

I've been having trouble with my wipers not working. I finally got somewhere. Replaced the motor and it's gotten better.

the issue now is I only have 2 clicks for my wiper.
If I push forward the wash kicks on of 5 wipes. First click gives me a long delay, second gives me a shorter delay, if I push it further I get the washer spray to kick on and it runs for 5 wipes and goes back to delay.


Looking at rockauto, there is only 1 option for a 90 burb. DS1586. that year intermittent was the only option.

in 88 there was a ds811 and it had only hi and low. 7 wire vs 5 wire. So I know I have the right switch.

is something not installed correctly or do I have a bad switch?

It feels like the wash option comes one too soon and I might have installed the switch with the wash on the wrong setting.

Anyone else run into this?

when the torrential rains come, I need the hi option...

Thanks
__________________
1990 suburban r1500 k 350 2wd
snowball is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com