The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1960 - 1966 Chevrolet & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 03-31-2018, 01:20 AM   #1
Cooper197
Registered User
 
Cooper197's Avatar
 
Join Date: Jul 2014
Location: Eugene, Oregon
Posts: 196
Turn Signal Issue

I just finished up re-wiring my '66, so I'm assuming the issue is that I have something backwards.

When I use the turn signals, the front light up and the dash indicator turns on but stay constant, neither blink. The rear lights do not come on at all, however the brake lights do work along with all park lights.

I have all LED lights and used an LED flasher before I did the rewire. I popped that in just to see if it made a difference and with that absolutely nothing happens when you hit the turn signal.

I've double checked the wiring, but it all seems to look correct. Anybody have an idea on what could cause such an issue?

*Problem solved. LED flasher ended up being bad. All works great with a new one*

Last edited by Cooper197; 03-31-2018 at 11:49 PM.
Cooper197 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:30 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com