The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 05-01-2019, 05:50 PM   #1
pound41
Registered User
 
Join Date: Dec 2002
Location: Northern Virginia
Posts: 1,130
po2135 GMC 2500HD 8.1

Hello I have a 2003 GMC 2500HD 8.1 that I am the original owner of. 168k
Back in 2003/04 I had only owned the truck a few months One morning in the the dead of winter I drove it to the store to get my morning coffee. Got back in started it up it shook. Reduced Engine Power came on. Tried to start again it fired right up. I called the dealer. he said not sure what that is if it happens again bring it in. It didn't happen for a few years. Then it would only happen in winter and never on the first start up. At one point many years ago I was told pedal assembly. It was changed still same issue. I let it go because it was only in the winter and didn't effect when driving.It started taking more tries to get it going so Last December we changed the connector at the throttle body. It was fine for a few weeks. Then for the 1st time in 16 years it did it while I was driving. We have cleaned the grounds. Put on a new GM throttle body. Found a few broken wires. Switch the TAC module. When ever you make a change it runs for 30 minutes and quits. Last week drove it 15 miles to work it was fine drove back home about 12 miles it quit running. Did that 2 days straight then next 2 days nothing. TPS 1 is at 4.8 volts with the connector plugged in TPS2 is at 4.2 volts. If you unplug the harness TPS goes up to 4.8 volts. Running out of ideals. I kept thinking wiring even though they all check out. When TPS2 is unplugged and jumps to 4.8 shows me it can carry the 4.8. Could it be the pcm.
pound41 is offline   Reply With Quote
Old 05-02-2019, 02:35 PM   #2
cashforclunkers
Active Member
 
cashforclunkers's Avatar
 
Join Date: Apr 2016
Location: Orrington, ME
Posts: 108
Re: po2135 GMC 2500HD 8.1

May sound stupid but have you checked for water in your fuel? I have had very similar symptoms and that ended up being it.
cashforclunkers is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:09 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com