The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 05-06-2019, 04:56 PM   #1
loudenzak
Registered User
 
Join Date: Oct 2018
Location: Grand Forks, ND
Posts: 2
Running tail lights but not brake lights?!

So i have been troubleshooting some brake light issues. When I pull the headlight switch for my running lights, I have them. Front and back. But when I press the brake, nothing happens. Now I went down and used a test light to see if there was anything coming to the brake switch and nothing. I dont know where to go from here. Any help please! I checked the filaments as well. all good there.
loudenzak is offline   Reply With Quote
Old 05-07-2019, 12:36 AM   #2
67 Burb
Registered User
 
67 Burb's Avatar
 
Join Date: Dec 2011
Location: Brandon, Manitoba, Canada
Posts: 482
Re: Running tail lights but not brake lights?!

Fuses OK? What happens with the turn signals? Are they working?
__________________
Bob

1967 2wd Burb, 350/TH350, 3.73 posi
67 Burb is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:39 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1997-2013 67-72chevytrucks.com