The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board > The 1973 - 1991 Blazers, Jimmys, and Suburbans Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 03-10-2018, 08:51 PM   #1
91r2500
Registered User
 
Join Date: Mar 2018
Location: Melrose, Florida
Posts: 1
91 R2500 4L80E problem

Hello, Welcome to my first thread
I am having an odd issue with my 4l80E.
When shifting automatically it skips second, it shifts through all other gears 1-3-4, does not slip, nor give any other problems.
When I shift it manually all gears work 1-2-3-4 no problem. It will not automatically downshift to 2nd either, 4th to 3rd is fine and if I go slow enough it will go into 1st as well, it will downshift to second if I manually put the shifter into 2nd though.

I have replaced all of the solenoids and wiring harness in the trans., rewired the external harness (someone did the conversion to the newer harness but the connections looked iffy) While resplicing the connector I checked to make sure that the wires were in their proper places.

Anyone have any ideas?
Thank you in advance for any help.

Last edited by 91r2500; 03-10-2018 at 08:53 PM. Reason: missing info.
91r2500 is offline   Reply With Quote
Old 03-28-2018, 06:51 AM   #2
85raiderburban
Registered User
 
85raiderburban's Avatar
 
Join Date: Nov 2014
Location: between AZ & NV
Posts: 53
Re: 91 R2500 4L80E problem

I've got a 4l80 in my 80 suburban. I shift it manually. Going from 1st to 3rd skipping 2nd is an indicator of solenoid B powered on too early. Both solenoids have to be off to get 2nd gear.
As follows:
1st - A ON, B OFF
2nd - BOTH OFF
3RD - A OFF, B ON

the computer/TCM is the obvious culprit here, as you wouldn't be able to shift it in all gears manually if it was something internal.
__________________
*UNDER CONSTRUCTION*
'80 Suburban C20 (C6P) (Silverado) 31's F / 33's R
- '68 472 (Edelbrock 1813, PH8026 LT's, H pipe) / '96 4L80 TSS / 14B FF 3.21 gov lock / '95 GMT400 gauge cluster
85raiderburban is offline   Reply With Quote
Old 03-28-2018, 12:51 PM   #3
Ski-me
Registered User
 
Ski-me's Avatar
 
Join Date: May 2012
Location: Colo Springs, CO
Posts: 701
Re: 91 R2500 4L80E problem

^^^ I have no idea but that sounds pretty dang logical!
__________________
- Jeff

89' K5 Blazer, 2.5" lift, 35" tires
04' GMC Yukon XL, 3/4 ton, 8.1L
Ski-me is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com