The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > S10 S15 Luv Blazer II

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 02-18-2009, 08:33 PM   #1
chevymotocross
Registered User
 
chevymotocross's Avatar
 
Join Date: May 2007
Location: East Haven, CT
Posts: 872
92 s10 blazer idle problems

I'm stumped with my fathers 92 s10 blazer with the TBI 4.3. The truck will not start cold without holding your foot on the pedal. Once started, it will idle, but very low, sometimes, it may even stall if put into gear too quickly. Once completely warmed up, it will idle, but still low. Engine runs strong otherwise.

I did voltage checks with the TPS, checks out fine. Did meter tests with the IAC, those tests came out fine as well.

Checked for vacuum leaks and found none.

What else should I be checking?
__________________
87 Chevy 2wd SWB: 305/700r4 Dual Exhaust, K&N Filter, Injector Pod Spacer, TBI Spacer, Belltech Front Sway Bar, Corvette Servo, Western Chassis 4/6 and c-notch
chevymotocross is offline   Reply With Quote
Old 02-19-2009, 07:25 AM   #2
BarryB
Senior Member
 
BarryB's Avatar
 
Join Date: Jul 2006
Location: Blountville, Tn.
Posts: 3,906
Re: 92 s10 blazer idle problems

Does that year have the cold start injector? I know some of the TPI had a cold start injector on them. I not sure but thats my .02 worth.
__________________
*We could learn a lot from crayons... Some are sharp; some are pretty;and some are dull. Some have weird names; and all are different colours;but they all have to live in the same box.

* You may be only one person in the world, But you may also be the world to one person.

* Some mistakes are too much fun to only make once.

Two rules in life.
1. Never sweat the small stuff!
2. Everything is small stuff!
BarryB is offline   Reply With Quote
Old 02-19-2009, 12:52 PM   #3
Damien
Registered User
 
Damien's Avatar
 
Join Date: Mar 2007
Location: Mankato, MN
Posts: 852
Re: 92 s10 blazer idle problems

Check the coolant temp sender. It serves the same function as a choke. It is on the top of the intake manifold near the t stat housing and has two wire coming out of it.
__________________
'83 swb 2wd
'74 K5 Blazer
'91 s10 swb 2wd
'02 T/A 6 Spd.
'63 Riviera 401
Damien is offline   Reply With Quote
Old 02-19-2009, 01:13 PM   #4
speed
Junior Member
 
speed's Avatar
 
Join Date: Jan 2006
Location: Northern Iowa
Posts: 258
Re: 92 s10 blazer idle problems

Did you check the fuel pressure before the regulator.
__________________
Jeff J
----------
86 El Camino
81 Monte Carlo
81 Regal
04 Colorado
speed is offline   Reply With Quote
Old 02-19-2009, 03:25 PM   #5
chevymotocross
Registered User
 
chevymotocross's Avatar
 
Join Date: May 2007
Location: East Haven, CT
Posts: 872
Re: 92 s10 blazer idle problems

Quote:
Originally Posted by speed View Post
Did you check the fuel pressure before the regulator.
This was something I was thinking of checking next. I have to get those gauge adapters though so I can tap in a gauge.
__________________
87 Chevy 2wd SWB: 305/700r4 Dual Exhaust, K&N Filter, Injector Pod Spacer, TBI Spacer, Belltech Front Sway Bar, Corvette Servo, Western Chassis 4/6 and c-notch
chevymotocross is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com