The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 99-06 Chevy and GMC Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 04-04-2010, 08:08 PM   #1
joeelutz
Registered User
 
joeelutz's Avatar
 
Join Date: Jan 2010
Location: Granite Falls, NC
Posts: 104
05 Silverado codes PO131 PO171 PO300

I've had trouble recently with my 05 Silverado 5.3L intermittently idling rough and running rough at low engine speeds. The check engine light came on and the exhaust smelled bad. I got the codes PO131, PO171, PO300 which suggest a lean condition on the left bank. However when I pulled the spark plugs, all the plugs on the left bank looked rich and the ones on the right looked normal. Well I disconnected the left front (pre-cat) O2 sensor and drove it today and it runs fine now although it does turn on the check engine light since the O2 sensor is disconnected. It appears that the O2 sensor was giving a false lean signal and the computer was over richening the left bank to try to compensate. So I'm going to install a new sensor tomorrow. I'm glad it wasn't a cracked intake.

I just thought this may help someone experiencing the same problems.
joeelutz is offline   Reply With Quote
Old 04-04-2010, 09:18 PM   #2
Hart_Rod
**Boomer Sooner!**
 
Hart_Rod's Avatar
 
Join Date: Apr 2005
Location: FL Panhandle
Posts: 13,408
Re: 05 Silverado codes PO131 PO171 PO300

Quote:
Originally Posted by joeelutz View Post
I've had trouble recently with my 05 Silverado 5.3L intermittently idling rough and running rough at low engine speeds. The check engine light came on and the exhaust smelled bad. I got the codes PO131, PO171, PO300 which suggest a lean condition on the left bank. However when I pulled the spark plugs, all the plugs on the left bank looked rich and the ones on the right looked normal. Well I disconnected the left front (pre-cat) O2 sensor and drove it today and it runs fine now although it does turn on the check engine light since the O2 sensor is disconnected. It appears that the O2 sensor was giving a false lean signal and the computer was over richening the left bank to try to compensate. So I'm going to install a new sensor tomorrow. I'm glad it wasn't a cracked intake.

I just thought this may help someone experiencing the same problems.
Which sensor is it? I've got 2 new rear ones that came off of the motor I put in my burb. Let me know, maybe we can work a partial trade on those covers, .
__________________
Rob - http://instagram.com/hart_rod

As Iron Sharpens Iron, So One Man Sharpens Another. Proverbs 27:17

69 SuperBurb - "My grandpa used to have a Suburban exactly like that."
http://67-72chevytrucks.com/vboard/s...d.php?t=200387

68 S/C Farm truck: 6.2/6L80/TVS1900/PaddleShifters
http://67-72chevytrucks.com/vboard/s...d.php?t=358692

SHIFTED: http://67-72chevytrucks.com/vboard/s...d.php?t=551258

1948 5 Window Chevy http://67-72chevytrucks.com/vboard/s...=122164&page=3

FAQ: http://67-72chevytrucks.com/vboard/f...play.php?f=220
Hart_Rod is offline   Reply With Quote
Old 04-05-2010, 12:45 PM   #3
joeelutz
Registered User
 
joeelutz's Avatar
 
Join Date: Jan 2010
Location: Granite Falls, NC
Posts: 104
Re: 05 Silverado codes PO131 PO171 PO300

Quote:
Originally Posted by Hart_Rod View Post
Which sensor is it? I've got 2 new rear ones that came off of the motor I put in my burb. Let me know, maybe we can work a partial trade on those covers, .
Thanks for the offer, but it's a front sensor.

Joe
joeelutz is offline   Reply With Quote
Old 04-06-2010, 09:18 PM   #4
Black 95 TSI
Registered User
 
Join Date: Jan 2007
Location: Alexandria VA
Posts: 77
Re: 05 Silverado codes PO131 PO171 PO300

I think all the sensors are the same,I know the 6.0 vans are. The o2s are caausing alot of running rought and code po300 codes. We have a fleet account at work and there trucks and vans are coming in at least once a week for this.
__________________
70 C10 SWB stepside forsale
00 Silverado Z71 Sold
95 Eagle Talon TSI turbo (Hellz ya its fast)
70 Chevelle
69 firebird
10 Silverado 4x4
Black 95 TSI is offline   Reply With Quote
Old 04-21-2010, 08:38 PM   #5
hatchaddict
Registered User
 
Join Date: Feb 2010
Location: pittsburgh, pa
Posts: 184
Re: 05 Silverado codes PO131 PO171 PO300

be careful not to drive it long like this cause these trucks love to burn cats shut
hatchaddict is offline   Reply With Quote
Old 04-22-2010, 06:21 AM   #6
truckdude239
Senior Member
 
truckdude239's Avatar
 
Join Date: Sep 2005
Location: Lewisville, Nc
Posts: 8,881
Re: 05 Silverado codes PO131 PO171 PO300

yes i have alot a few of these truck come though my shop with melted cats
__________________
David fuller
Ase Certified Mechanic
Click here to help support our board!!

1971 Chevy c-10 under going a 4.8l LSx swap

Build Thread http://67-72chevytrucks.com/vboard/s...d.php?t=421305

1987 Ford F-150 302 v8 auto -
1999 Honda accord 2 door with 238k miles my daily driver
2002 Honda Accord 4 door With 244k (sisters car)
1998 Honda Accord 4 door with 301k (brothers car)

General manager for Marco's Carwash & lube
truckdude239 is online now   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 1997-2013 67-72chevytrucks.com