The 1947 - Present Chevrolet & GMC Truck Message Board Network

The 1947 - Present Chevrolet & GMC Truck Message Board Network (https://67-72chevytrucks.com/vboard/index.php)
-   The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board (https://67-72chevytrucks.com/vboard/forumdisplay.php?f=4)
-   -   Electrical issue. (https://67-72chevytrucks.com/vboard/showthread.php?t=823799)

eighteenninetytwo 07-15-2021 01:46 PM

Electrical issue.
 
Soooo for the last week or so my 75 blazer (350 SBC) has been struggling to stay running at low revs. Yesterday there was a bit of electrical smell and a tiny bit of smoke form under the dash. At least one fuse (gauge cluster) has gone and when I tried to restart to check and removed the air cleaner I found the electrical choke stuck open, not adjustable manually at all.

Going to remove dash later to see if there is anything SUPER obvious like a short or touching / loose wires, but any ideas?

old Rusty C10 07-16-2021 11:03 AM

Re: Electrical issue.
 
may want to post in electrical too

eighteenninetytwo 07-16-2021 12:50 PM

Re: Electrical issue.
 
Seems I had two separate issues. I found a short circuit and some melted wire cover in a wire that went to a button for the gauge cluster. Contact with metal (or poor installation) had worn through the insulation so the wire touched the metal plate as it passed through. It had got hot enough to melt 4 inches or so of wire insulation, hence the smoke I saw. This lower bit of the dash had been loose for a while.

The running / stalling at low revs choke issue had started a few days before the burning thing so I suspect they aren't related but just happened along at the same time.


All times are GMT -4. The time now is 10:39 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com