The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 08-19-2021, 07:59 AM   #1
lukbrw
Registered User
 
lukbrw's Avatar
 
Join Date: Feb 2008
Location: Shawano, WI
Posts: 94
64 c20 Single wire Alternator not charging

Looking to get some advice on a charging system. previous owner did the single wire upgrade to the 64 c20 that we picked up. All the wiring looks correct and there is a resistor under the dash that is lighting up with no issues. Everywhere we test we only get 12.4v going back to the battery.

Replaced a few ends and cleaned up the terminals but no change.

Alternator was bench tested at Oreilly's with no issues.

Brown, blue, and white wires that went to the old external regulator are not connected to anything as described in previous posts.

We put in a new battery, but the old battery had the same amount of voltage.

Any suggestions on something that needs to change or check?
Attached Images
     
lukbrw is offline   Reply With Quote
Old 08-19-2021, 08:31 AM   #2
lukbrw
Registered User
 
lukbrw's Avatar
 
Join Date: Feb 2008
Location: Shawano, WI
Posts: 94
Re: 64 c20 Single wire Alternator not charging

Could the issue be that the previous owner connected the red lead directly to the power output on the back of the alternator instead of going to the junction on the core support?
Attached Images
 
lukbrw is offline   Reply With Quote
Old 08-19-2021, 10:56 PM   #3
Dead Parrot
Registered User
 
Join Date: Aug 2012
Location: Oklahoma City, OK
Posts: 1,883
Re: 64 c20 Single wire Alternator not charging

A true 1 wire alt doesn't need that white 2 wire connector. If yours does, then it is a standard alternator. Try running the red voltage sense wire to the junction box(if present) or to the battery. Yes, that means you will have both red wires going to the same place but that is how the 10/12 SI internal regulated alternators are designed. The red voltage sense wire picks up the voltage from where it is connected and adjusts the output of the alt to reach the desired voltage at that location. This lets it cancel out any voltage losses in the main charging wire.
Dead Parrot is offline   Reply With Quote
Old 08-20-2021, 08:23 AM   #4
lukbrw
Registered User
 
lukbrw's Avatar
 
Join Date: Feb 2008
Location: Shawano, WI
Posts: 94
Re: 64 c20 Single wire Alternator not charging

Thanks! Will give that a try.
lukbrw is offline   Reply With Quote
Old 08-21-2021, 07:27 AM   #5
bob arrington
Junior Member
 
Join Date: Dec 2018
Location: Clitherall
Posts: 56
Re: 64 c20 Single wire Alternator not charging

the white wire in that plug makes the alternator start charging immediately instead of having to hit 1000 rpms to start charging, if it were mine, and it was cause I just went thru this with a newly installed 160 amp , Id double check the ground, over time you will like the instant charge function that that white wire provides
bob arrington is offline   Reply With Quote
Old 08-21-2021, 01:48 PM   #6
lukbrw
Registered User
 
lukbrw's Avatar
 
Join Date: Feb 2008
Location: Shawano, WI
Posts: 94
Re: 64 c20 Single wire Alternator not charging

Ran the red wire coming out of the battery and still only getting 12.43 v coming out of the alternator and at the battery. Will start taking more apart but assuming doming isnít causing the regulator to send voltage.

Thoughts?
lukbrw is offline   Reply With Quote
Old 08-22-2021, 07:59 AM   #7
VetteVet
Msgt USAF Ret

 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,560
Re: 64 c20 Single wire Alternator not charging

Go to the home page of this forum and check my Electrical Faqs and look at the threads on
converting to an internal regulated alternator. Also look at the thread on why won't my battery charge.
__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Old 08-22-2021, 11:03 AM   #8
lukbrw
Registered User
 
lukbrw's Avatar
 
Join Date: Feb 2008
Location: Shawano, WI
Posts: 94
Re: 64 c20 Single wire Alternator not charging

Replaced a few wires and connections. Battery is now charging under acceleration! Thanks for the advice.
lukbrw is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:20 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com