The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1988 - 1998 GMT400 Chevy & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 05-20-2020, 01:28 PM   #1
Gunner41
Registered User
 
Gunner41's Avatar
 
Join Date: May 2011
Location: San Jose, Ca
Posts: 86
Linear EGR

Morning guy sorry for the long question.

Yeah I'm still working on my truck and yall have been my hero's. Todays issue is Im in the process of smoging my truck (97 3500 7.4 all kinds of stock).
I just replaced the head gaskets and all the fun stuff. When I put it together the only code in the sys was bank 2 sen 1 o2 which I replaced and cleared the code. My OBD reader checked for I/M readiness and out of the six sensors required two lit up. I did the clearing drive (don't remember what they called it) but it reset one (o2 htr) so now yes I can pass smog (Ca) I still have a problem with EGR. I removed and cleaned it hoping that it would fix the problem.
Well that didn't work so I installed it and unplugged to test and it has power coming into it. Now I'm stuck. I have VERY limited experience with my multi-meter and am still learning. Any suggestions?
Gunner41 is offline   Reply With Quote
Reply

Bookmarks

Tags
egr, linear egr, smog

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:58 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 1997-2022 67-72chevytrucks.com