The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1967 - 1972 Chevrolet & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 05-26-2016, 06:21 PM   #1
Chilly178
Registered User
 
Chilly178's Avatar
 
Join Date: May 2016
Location: Green Bay, WI
Posts: 119
Lightbulb 72 C20 Turning lights not working?

Hello, I own a 1972 C20, and the turning lights don't seem to be working at all. The light blue and dark blue wires got really hot and melted so I replaced all the burnt wire and I put in a new fuse. After that the wires still were getting hot so I didn't do it for long. I have two different turning light harness in the steering wheel and the new one that came with an adapter for the plug in under the dash. Well this adapter got hot as well and melted so now I can't use the new one so I went back to the old harness without the adapter. So its still breaking fuses constantly, and the flasher gets way too hot. Its only the front blinkers that are not working, both rears work. I also did something earlier on and manged to get the left front one working but it was blinking fast and the right side was not working at all. I am not sure if it is still like this or it doesn't work all together. I also made sure that the front turning lights were in fact ground to the front bumper. So do I take the fuse box under the dash off and do some investigating there? Or should I buy a new steering wheel harness for the turning lights again? Is something not grounded or is it a short somewhere? Do I need to buy a whole new wiring harness for this simple problem? It's very frustrating to me because I can't seem to figure it out and two simple turning lights is preventing me from driving the truck so there it sits. Any ideas?
Chilly178 is offline   Reply With Quote
Old 05-26-2016, 11:43 PM   #2
LockDoc
The Older Generation

 
LockDoc's Avatar
 
Join Date: Aug 2006
Location: Montezuma, Iowa
Posts: 23,343
Re: 72 C20 Turning lights not working?

Quote:
Originally Posted by Chilly178 View Post
Hello, I own a 1972 C20, and the turning lights don't seem to be working at all. The light blue and dark blue wires got really hot and melted so I replaced all the burnt wire and I put in a new fuse. After that the wires still were getting hot so I didn't do it for long. I have two different turning light harness in the steering wheel and the new one that came with an adapter for the plug in under the dash. Well this adapter got hot as well and melted so now I can't use the new one so I went back to the old harness without the adapter. So its still breaking fuses constantly, and the flasher gets way too hot. Its only the front blinkers that are not working, both rears work. I also did something earlier on and manged to get the left front one working but it was blinking fast and the right side was not working at all. I am not sure if it is still like this or it doesn't work all together. I also made sure that the front turning lights were in fact ground to the front bumper. So do I take the fuse box under the dash off and do some investigating there? Or should I buy a new steering wheel harness for the turning lights again? Is something not grounded or is it a short somewhere? Do I need to buy a whole new wiring harness for this simple problem? It's very frustrating to me because I can't seem to figure it out and two simple turning lights is preventing me from driving the truck so there it sits. Any ideas?
It sounds like you have a short somewhere but I am not sharp enough on this stuff to figure it out in my head. I'm sure I could if I was there looking at it though. Is there a lot of rust in the fuse holders?

LockDoc

p.s. Welcome to the board
__________________
Leon

Locksmith, Specializing In Antique Trucks, Automobiles, & Motorcycles

(My Dually Pickup Project Thread)

http://67-72chevytrucks.com/vboard/s...d.php?t=829820

-
LockDoc is offline   Reply With Quote
Old 05-27-2016, 12:50 AM   #3
66clow
Registered User
 
66clow's Avatar
 
Join Date: Jun 2012
Location: Clearwater Beach Florida
Posts: 872
Re: 72 C20 Turning lights not working?

I just figure my wiring issues out. I didn't figure it out until I went thru all of my wiring. It takes a lot of time but you'll eventually find the problem. Lots of great help but start with this.

66clow is offline   Reply With Quote
Old 05-31-2016, 08:59 PM   #4
Chilly178
Registered User
 
Chilly178's Avatar
 
Join Date: May 2016
Location: Green Bay, WI
Posts: 119
Re: 72 C20 Turning lights not working?

Yeah thanks, the fuses look good and nothing looks corroded, but the turning light fuse keeps popping, so i'm not sure. Thanks for the diagram as well 66clow.
Chilly178 is offline   Reply With Quote
Reply

Bookmarks

Tags
electrical issue, ground, problem, short, turn signal issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:27 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 1997-2022 67-72chevytrucks.com