The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > Info Center > FAQ Truck Tech > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 06-12-2021, 05:17 PM   #1
Chiefdan
Registered User
 
Chiefdan's Avatar
 
Join Date: Nov 2020
Location: Fredonia
Posts: 28
Alternator spikes

Ok, this isn't for my Chevy C10 but this is the only automotive board I subscribe to so maybe you guys can help me. 1964 Nova Gasser, 383 stroker, 4 speed. I put a 1 wire chrome alternator in with battery in the trunk. 10 guage wire from alternator to cut-out switch in the trunk and then to the battery. The other night the voltmeter read all the way to the right (18+ volts). When I stopped the car it would not start because of blown 40 amp fuse in the wire from alternator to cut-out switch. New fuse and it started and ran normally with meter reading around 13 v. Am I looking at an alternator problem or possibly something else? Thanks for the help. Chief
Chiefdan is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:52 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com