The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 06-08-2010, 10:47 PM   #1
turner15
Registered User
 
Join Date: Jan 2007
Location: Toronto Canada
Posts: 265
Main fuse? I have no power

Is there a main fuse in my 80? I have now power anywhere. New battery clean connections? No power of any kind. Just wouldn't restart one time.
turner15 is offline   Reply With Quote
Old 06-08-2010, 10:54 PM   #2
81ratrodc10
house of chevy's
 
81ratrodc10's Avatar
 
Join Date: May 2010
Location: New milford, CT
Posts: 583
Re: Main fuse? I have no power

i had same prob try the fusable link off the distrbution block that fixed it for me
__________________
1987 m1028 cucv d30
2001 chevy s10
2000 honda shadow sabre 1100


"it's going to be an interesting ride home"
81ratrodc10 is offline   Reply With Quote
Old 06-09-2010, 07:34 AM   #3
turner15
Registered User
 
Join Date: Jan 2007
Location: Toronto Canada
Posts: 265
Re: Main fuse? I have no power

I have a carb setup? Distributor no computer do I still have a fusible link?
turner15 is offline   Reply With Quote
Old 06-09-2010, 07:43 AM   #4
RandyP
Getting Old; Going Broke
 
RandyP's Avatar
 
Join Date: Apr 2010
Location: Owasso OK
Posts: 2,764
Re: Main fuse? I have no power

You have several fusible links actually. Main one being on the firewall sorta top center, other being on the starter wiring. Is a normal looking wire with a black sealed fuse link built in to it, test both sides of the inline fuse and see if power is going through it or not. Easy to check.
RandyP is offline   Reply With Quote
Old 06-09-2010, 05:36 PM   #5
turner15
Registered User
 
Join Date: Jan 2007
Location: Toronto Canada
Posts: 265
Re: Main fuse? I have no power

thanks it was a lose starter connection. However now I have no spark? Could I have done something? I just tightened the 2 connectors on the starter and I got it turning over again but it didn't start so I checked for spark and nothing? Maybe that is the other fusible link mentioned above?
turner15 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:26 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com