The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 07-15-2021, 01:46 PM   #1
eighteenninetytwo
Registered User
 
Join Date: Sep 2013
Location: Redwood city, CA
Posts: 689
Electrical issue.

Soooo for the last week or so my 75 blazer (350 SBC) has been struggling to stay running at low revs. Yesterday there was a bit of electrical smell and a tiny bit of smoke form under the dash. At least one fuse (gauge cluster) has gone and when I tried to restart to check and removed the air cleaner I found the electrical choke stuck open, not adjustable manually at all.

Going to remove dash later to see if there is anything SUPER obvious like a short or touching / loose wires, but any ideas?

Last edited by eighteenninetytwo; 07-15-2021 at 02:32 PM.
eighteenninetytwo is offline   Reply With Quote
Old 07-16-2021, 11:03 AM   #2
old Rusty C10
Robert Olson Transport
 
old Rusty C10's Avatar
 
Join Date: Oct 2002
Location: Howell NJ USA and a house in Deposit NY USA
Posts: 20,010
Re: Electrical issue.

may want to post in electrical too
__________________
Bob



1979 Chevrolet C20 LWB
1998 Chevrolet K2500 LWB
1971 Chevrolet Monte Carlo
1966 Ford Mustang
2019 Ram Bighorn 3500 SLT 4X4 Longbed Diesel
2005 Dodge 1500 SWB 4X4
2014 Harley Davidson Heritage Softtail


"If a man's worth is judged by the people he associates himself with, then i am the richest man in the world knowing some of the fine people of this board"
http://67-72chevytrucks.com/vboard/a...t.php?f=25&a=9 (you can review the site rules here!)


PM Me for your vehicle/parts hauling needs in the North East US or see my Facebook page Robert Olson Transport

Live each day to the fullest.. you never know when fate is going to pull the rug out from under you...
I hate cancer!!
old Rusty C10 is offline   Reply With Quote
Old 07-16-2021, 12:50 PM   #3
eighteenninetytwo
Registered User
 
Join Date: Sep 2013
Location: Redwood city, CA
Posts: 689
Re: Electrical issue.

Seems I had two separate issues. I found a short circuit and some melted wire cover in a wire that went to a button for the gauge cluster. Contact with metal (or poor installation) had worn through the insulation so the wire touched the metal plate as it passed through. It had got hot enough to melt 4 inches or so of wire insulation, hence the smoke I saw. This lower bit of the dash had been loose for a while.

The running / stalling at low revs choke issue had started a few days before the burning thing so I suspect they aren't related but just happened along at the same time.

Last edited by eighteenninetytwo; 07-16-2021 at 12:57 PM.
eighteenninetytwo is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com